powered by Jive Software

Cannot login on admin after install

I know this problem has been posted before…

tried all of the things they sad.

tried rebooting, tried giving priv to the user of openfire.

found something to add to the xml but dont know where

and my xml file looks kind of to small

<?xml version="1.0" encoding="UTF-8"?> <!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>     Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive>   <adminConsole>     <!-- Disable either port by setting the value to -1 -->      <port>9090</port>      <securePort>9091</securePort>   </adminConsole>    <locale>en</locale>    <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->    <!--
    <network>
        <interface></interface>
    </network>
    -->    <connectionProvider>     <className>org.jivesoftware.database.DefaultConnectionProvider</className>   </connectionProvider>    <database>     <defaultProvider>       <driver>com.mysql.jdbc.Driver</driver>        <serverURL>jdbc:mysql://mysql123.myserver.org:3306/openfire2</serverURL>
      <username>myusername</username>        <password>mypass</password>        <testSQL>select 1</testSQL>        <testBeforeUse>true</testBeforeUse>
      <testAfterUse>true</testAfterUse>        <minConnections>5</minConnections>        <maxConnections>25</maxConnections>        <connectionTimeout>1.0</connectionTimeout>     </defaultProvider>   </database>    <setup>true</setup> </jive>

thats all i found at least

suggestions how to fix?

...</adminConsole>  <admin>
<authorizedJIDs>admin@example.com</authorizedJIDs>
</admin>
<locale>en</locale>...

thx for the answer but it didnt fix it

Hi,

can you login with an XMPPclient using the admin account? You may want to create a new account using your XMPP client and add it to authorizedJIDs in openfire.xml, this should work fine.

LG