powered by Jive Software

Cannot Login to Admin Console Openfire 3.6.4

I was wondering maybe someone here can shed some light in this problem. I have recently installed the latest version (3.6.4) of openfire but got stuck in admin console panel. I used mysql to store the users. I can access the admin console using this link but when I logged in using admin username, it will always display the following error in red,

“Login failed: make sure your username and password are correct and that you’re an admin or moderator.”

I have tried the methods described in other posts including editing the database to use PlainPassword but still got no luck as well as editing openfire.xml

Edit: I checked again and it seem that I can only access the port 9090 and not port 9091

Solution: Rebooting the server solved the problem. phew

Thanks for the great software guys. Keep up the good work specially the Spark Client.

I am having same problem. Using embedded database. Windows. Have unintalled 3.6.4 and deleted C:\Program Files\Openfire and reinstalled five times now, including two server restarts. Am typing very carefully and am fairly confidant I am not fat fingering anything. But cannot get past that same error: “Login failed: make sure your username and password are correct and that you’re an admin or moderator.”

I did successfully install and run 3.6.4 on another Windows machine last week - am out of ideas. Thanks in advance for any suggestions.

Have you tried editing the admin PlainPassword in your ofUser database? Or emptying the contents in ofProperty table?

Thanks for the quick help goldenfox, I think I am all set now. I read elsewhere advice to restart the server - but what I had not done was restart the server AFTER installing Openfire. This time, following the installation, prior to logging in as admin, I merely stopped and started Openfire and now I am able to log in. Unlike the successful installation I ran on another PC last week, I noticed in this installation’s log the fllowing note:

2009.05.11 09:22:36 Openfire 3.6.4 [May 11, 2009 9:22:36 AM]
2009.05.11 09:22:38 Admin console listening at
2009.05.11 09:23:20 Missing database schema for openfire. Attempting to install…
2009.05.11 09:23:20 Database update successful.

…so don’t know why then restarting OpenFire fixed the problem - perhaps the database was not put completely back online or something. Anyway thanks for the help.

Same here. Tried restarting openfire but doesn’t work, tried rebooting the server and I can now login to admin console.

I have some problems about “Admin Console Openfire 3.6.4” are the followings (Ubuntu 8.10 (non-server edition)+ MySQL 5.0.x):

  1. Cannot use “Standard Database”. The connection refused. But, I can connect the database by database client tool from remote machine.

  2. Cannot pass the step of “change admin password” always. Skip this step, but “login to admin console” occurs exception. (solved if I do not select “standard database” in prior step).

I wonder about why many issues in “openfire setup” processes. This is not acceptable in a system installation.

  1. In MySQL if connection is refused then you might have missed something in pivileges. Try to add local user too and test it.

  2. This might be related to your problem 1 as openfire tries to connect to MySQL.

I’m not able to log in with my custom existing member database. Using the latest Openfire installation on CentOS. I’ve modified the openfire.xml (with a stop and restart respectively) using the same code for user authentication of custom db, modified to match my existing members database down to the correct capitalization of the tables and admin console still will not let me in.

openfire.xml below:

select 1



SELECT password FROM members WHERE UserName=?

SELECT FirstName,Email FROM members WHERE UserName=?
SELECT UserName FROM members
SELECT UserName FROM members WHERE


The errors in the error.log I’m finding is the following if it’s relavent:

2009.05.18 19:21:51 [org.jivesoftware.openfire.plugin.emailListener.EmailListener.openFolder(EmailL istener.java:281)] Error while initializing email listener
at java.util.Hashtable.put(Hashtable.java:394)
at java.util.Properties.setProperty(Properties.java:143)
at org.jivesoftware.openfire.plugin.emailListener.EmailListener.openFolder(EmailLi stener.java:243)
at org.jivesoftware.openfire.plugin.emailListener.EmailListener.access$100(EmailLi stener.java:36)
at org.jivesoftware.openfire.plugin.emailListener.EmailListener$1.run(EmailListene r.java:80)
2009.05.18 19:26:52 [org.jivesoftware.openfire.archive.ArchiveIndexer.updateIndex(ArchiveIndexer.ja va:290)]
java.io.FileNotFoundException: /home/theraq/public_html/openfire/monitoring/search/segments (No such file or directory)
at java.io.RandomAccessFile.open(Native Method)
at java.io.RandomAccessFile.(RandomAccessFile.java:212)
at org.apache.lucene.store.FSIndexInput$Descriptor.(FSDirectory.java:430)
at org.apache.lucene.store.FSIndexInput.(FSDirectory.java:439)
at org.apache.lucene.store.FSDirectory.openInput(FSDirectory.java:329)
at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:45)
at org.apache.lucene.index.IndexWriter$1.doBody(IndexWriter.java:264)
at org.apache.lucene.store.Lock$With.run(Lock.java:99)
at org.apache.lucene.index.IndexWriter.(IndexWriter.java:259)
at org.apache.lucene.index.IndexWriter.(IndexWriter.java:244)
at org.apache.lucene.index.IndexModifier.init(IndexModifier.java:148)
at org.apache.lucene.index.IndexModifier.(IndexModifier.java:111)
at org.jivesoftware.openfire.archive.ArchiveIndexer.updateIndex(ArchiveIndexer.jav a:231)
at org.jivesoftware.openfire.archive.ArchiveIndexer$2.run(ArchiveIndexer.java:156)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

Any help would be appreciated. This is a production site with many users in the members list already and getting this to work would be a real good thing.


You made sure to create the database to which you’re trying to connect in openfire, right?

Yes i tried with Plain Password in to ofUser table but no luck . Should I try to empty the contents of ofProperty Table ?

Yeeh …! After emptying the ofProperty table , i reset the admin passwd during fresh installation , now i am able to login in to admin console … Cheers .

Thanks for your support

Pramod Ratnakar.

I just cleared “storedKey” , “serverKey” , “salt” , “encryptedPassword” for admin user in ofUser table.
Then i entered 123 to plainPassword, i logged on with 123 password to admin console and reset password for admin, its created new entries for all of “storedKey” , “serverKey” , “salt” , “encryptedPassword” values and working well now. (v.4.1.6)