powered by Jive Software

Cannot modify admin account

I just installed Jive Messenger 2.2.1 and all my accounts imported fine and are working properly, (i use mysql backend).

I can add accounts, modify and delete accounts, except the admin account.

I can’'t change the email or password on the admin account…

I granted full access to the jive user to the database as well, so I do not believe it to be a db permissions issue.

error.log

at org.jivesoftware.messenger.user.DefaultUserProvider.setPassword(DefaultUserProv ider.java:367)

at org.jivesoftware.messenger.user.User.setPassword(User.java:102)

at org.jivesoftware.messenger.admin.user_002dpassword_jsp._jspService(user_002dpas sword_jsp.java:90)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

thanks for your help in advance

I think the problem was that I migrated my users from an old jive messenger server using the userImportExport plugin and admin account was the only existing account on the new one that was overwritten by the plugin.

So once admin was copied over admin it got fauled or something so I ended up just deleting it and now im locked out of the admin panel Luckily I found in the xml config file there is a setting to specify extra admin names, I added myself and will try logging in when I have a chance to restart the server.

Either way I will update you guys on this issue (possible bug)

Hi Greg,

The userImportExport plugin should not import a user if their username already exists on the target Messenger installation. Which version of the plugin are you using? At the end of the import process the plugin will report back any users it wasn’'t able to import, do you remember seeing such a message for the admin user?

Thanks,

Ryan

the plugin worked but it just showed a blank screen after the import was finished. it was approximately 90 users.

Everything worked out in the end, I deleted the admin account and used the extra admin line in the jive-messenger-config.xml file and it works fine, this way I can divy out admin access to my users without giving away one coveted password.

Regards,

Greg

Plugin is working fine. I did import yesterday and it warned that admin user already exist and was not imported.