Cannot run spark after group policy deployed msi

I have it so that java (jre1.6.0_05.msi) and spark (spark_2_5_8_online.msi) are installed via a group policy to an XP SP2 machine. Everything with that works fine. But, if I try to run spark when logging in for the first time as a non-administrative user, spark won’t run. The process starts for a split second and then is gone from the task manager. It seems I have to run as administrator one time and then from then on it works for anyone logged into the xp machine? Anyone experience this before and know why?

Unfortunately I ran into this problem to when deploying spark the same way you did. The only way I could get around it was to let spark run as an administrator the first time. I’m not sure how else to get around it.

So, spark has to be run as an admin the first time, it does not store its settings in %APPDATA%, java cannot handle redirection for gettingts its user.home setting,…HOW is anyone using this in their enterprise? Are we the only users who have redirection and want to deploy using group policies?

I am also running into this issue - I have copied the config… but spark does not start when you run the executable for the first time as a regular user. Is there something else that needs to be scripted in order to get this working?

This appears to be one of many issues with the MSI installers for spark. For this reason I used a third party product to convert the exe installers to msi. I have not had any issues with deployment after doing this.

After some testing I’ve found that Spark will start on first-run as a regular user so long as they have read/write access to the “C:\Program Files\Spark” directory. Script away, but at this point though it’s probably just easier to repackage the setup.exe.

Please can you make a how to how u did it or upload your msi file? I tried it but i am very new in it…

Thank u so far,


I used this command to set the permissions:

CACLS c:\Progra~1\Spark /E /G Users:C

i built with the advanced installer a msi file from the exe.

This may be obvious but your GPO install is under “Computer Configuration” and not “User Configuration” (Software Settings), yes?

Yes Software Installation applied in Computer Configuration, but I leave both enabled because I also have a script that copies the file over that is part of the user logon script.

yep under computer configuration.

I use the msi MSI package that includes Java JRE (not the spark_2_5_8_online.msi). Same problem either way?