powered by Jive Software

Can't connect to AD via LDAP

I have just installed openfire 3.6.2 on a debian machine using a mysql database. I am getting stuck when trying to add users from Active Directory via LDAP. I am using DC=sandbox,DC=net for my base DN with is my domain. For username I am using CN=Openfire, CN=Users,dc=sandbox,dc=net. I get this error:

Test: Connection Settings

Status: Error

Error authenticating with the LDAP server. Check supplied credentials.

When in fact this user has proper credentials.

Help!!

can you post a screenshot? a picture is worth a thousand words.

attached

you have a space in your admin settings.

“CN=Openfire, CN=Users,dc=sandbox,dc=net”

I am sorry I didn’t realize because I have tried so many different things but this did not in fact fix the problem. I am still getting the ldap error message.

Thanks though

ensure your CN is fully populated, you are jumping from CN to DC, what about OU? if unsure, go google for softerra ldap browser (free version) to get the exact CN you need.

In active directory the default Users container is just that a CN not an OU. You do not need to have an OU if the user specified is in the default Users container.

Did you choose active directory form the server type, as it is not selected in the pics.

try using openfire@sandbox.net rather than breaking it all down, i have had to do this before and it works

what permissions in AD does openfire have ?

It worked using openfire@sandbox.net . Thank you so much!!!

i am just new to it all, but glad i could have been some help