powered by Jive Software

Can't connect to admin console - outdated/unsafe TLS settings

Since i updated to openfire 4.4 i’ve not been able to connect to the admin console. All browsers say there is an ssl version or cipher version mismatch or that its using outdated tls. Its likely that I missed some note to update the settings to allow newer tls or ciphers, etc, and now the browsers are blocking these old connections by default. Is there a way to configure the settings directly in the db properties to enable this? Im running on centos 7 with mariadb. Thanks!

What java version are you using?

java -version

Also, check Openfire logs, all.log file for more clues.

Hello all;
Hello Ryan.bohn;

I believe that Openfire has a problem with certificates, because for some time now I have a similar problem that I have not been able to solve yet (https://discourse.igniterealtime.org/t/openfire-cant-use-port-7443 -after-update-4-2-3-4-3-2 / 85597).

My problem is with the certificates and when trying to use some plugin that uses them, for example: inverse through port 7743 and the Openfire meeting.

I also use CentOS 7 and Mariadb. Beforer updating from version 4.2.3 to version 4.3.2 the plugins that needed certificates worked without problems, after the update to that version all stopped working. I currently use version 4.4.0 and still not work.

Sorry for my intrusion, but I think the problems are related.

Rommel

Hey all, just following up. I installed 4.4.2 and all is well again. It must have been a bug.

1 Like