Can't connect to my own server

I just installed openfire 3.5.2 for windows and I’ve tried connecting with both Miranda and Psi and both can’t connect. With Miranda, however, I’m able to register a new account, so at least something is working. When I try to connect with Psi, it first says “The certificate failed the authenticity test. Reason: Certiifcate is self-signed.” I press ‘Continue’ and it says “There was an error communicating with the server. Details: Authentication error: Not authorized” And when I try to connect with Miranda, it says, “Authentication failed for username@localhost.” Nothing shows under the Openfire status window. I’m running all the default settings. I haven’t changed anything. I also made sure that windows firewall is off, and my router’s firewall is off. I even tried setting up port forwarding but I still can’t connect.

Edit: I also tried using multiple different passwords and usernames after setting it up with openfire, and also tried using the ones I registered using Miranda. Still doesn’t work

You have Psi and Miranda installed on the same machine, so you are trying to connect with username@localhost credentials? If server and client is on the same machine you can also try username@computername.

Are you able to login to Administration Console? Psi error is strange as you said you havent done anything after setup. Certificates must be generated by admin in Admin Console, so i dont understand why Psi complains about that.

When configured Openfire you should have given the server a Fully Qualified Domain Name. This is the name you should use to connect to the server even if the client is on the same computer as Openfire. You can fix this by re running the setup by modifying the openfire.xml tag to read false, or you can manually change the settings in the openfire admin site. You need to change:

  • Server Name under Server Information
  • xmpp.domain under System Properties
  • Generate new certificates to match new FQDN