Can't connect to openfire server using spark!

Dear all,

this is my first post on this forums so please excuse my mistake.

I have just installed Openfire on my Ubuntu Server today as I have been recommended by many friends. But it seems like I can’t connect to my server at all. I used openfire installation package deb, with java6.

Many thanks in advance

We need much more information to be able to help you. About how you have setup everything, what is your network setup, how you created users, how you are trying to connect in Spark. Was you able to connect in Spark from the same computer where the server is installed (localhost)? If you are trying to connect from a remote computer and using server’s name, then make sure your server’s name is resolvable in the network or you can use IP address of the server (specify it instead of servername in Spark).

Hi there, thanks for your reply

The networking setup:

Host: Ubuntu Server 10.04

IP :

LDAP connection (I’m sure that LDAP was running fine cause I was being able to pull my user from LDAP to openfire)

I tried to connect openfire from remote machine using spark but I haven’tr tried to use it on the same machine, as it is Ubuntu Server so there is no GUI. I can install x11 if it is require. Further more I was using server IP address instead of the server name so it is pretty solid.

, I’m not really sure this will answer your question .

It is not required to have a GUI on a server. This is just the simpliest way to find out if there is a networking issue. I see that you have setup it with LDAP integration, so you have tried to login with AD user? This should work, but you can try to rule out this. Can you try reinstalling Openfire without LDAP integration, just with internal database and then create a local user in that installation and then try to connect with Spark form a remote machine with that user? Again, using IP address instead of server’s name.

Before that you can try one more thing with Spark. On login window click Advanced and enter server’s IP into Host field. Then go back to login window and enter server’s name in the field. Probably still won’t work.

I think that i found the problem, just maybe:

I tried to create new user from openfire admin console, but it said that

Not allowed: the user account system is read-only.

is this cause by openLDAP?

LDAP in general. If you are using LDAP then you cant create local users. This is normal.