powered by Jive Software

Can't connect to Openfire server

I’ve got Openfire installed and set up, pointing to my domain. I can get to the admin console from mydomain.com:9090, I’ve got a FQDN set up at xmpp.mydomain.com, the console recognizes my SRV records and passes the DNS check, and I can ping both mydomain and xmpp.mydomain.com. My firewall is set to allow tcp and udp connections through 5222 and 5269. The service is running.

As far as I can tell, everything should be working, but when I try to connect as myusername@xmpp.mydomian.com from any client, I get “server not found”. Since there’s no connection being made to the server, I don’t have any error logs to tell me what the problem even is.

Is there anything else I should be looking at / neglected to configure? Any other information you’d need? I’ve followed every installation guide I can find, and I’m at a complete loss. There must be some simple thing I’m not seeing, but I just haven’t been able to find it.

Help me, Openfire Support Community. You’re my only hope.

If you have SRV records correct, you would connect as myusername@mydomain.com, that URL for the admin console would not be accurate in this instance as the SRV record would not work for HTTP(s) connections

So what does it mean that mydomain.com:9090 DOES work? Is that indicative of anything?

Connecting as username@mydomain.com yields the same result.

It means that HTTP connection is forwarded to your Openfire server on 9090 port. XMPP client is not a browser and it needs something different.

What is your XMPP Domain Name (shown on Admin Console)? Is it mydomain or mydomain.com? In the client you should put exactly what is shown there. If it doesn’t work, then you don’t have a correct SRV record for a client trying to find 5222 port on ‘you_exact_domain’ and pointing to xmpp.mydomain.com machine. Which is your Server Host Name (FQDN) as it shown on Admin Console, isn’t it? If it isn’t xmpp.mydomain.com, then your SRV record is pointing to a wrong place. Although you say that SRV check is fine, so there shouldn’t be a problem.

Anyway, in Spark i would also try to put ‘your_exact_domain’ as Domain and in the Advanced settings would put your server’s IP (or external IP, if it’s a local server behind a firewall with a port 5222 forwarded to that server) into a host field. If that works, then at least your firewall is not the case.

Also, you only need tcp. And 5269 is for Server to Server connections (if you need it).

It’s definitely not a port forwarding issue, I turned the firewall completely off as an experiment and I’m still not able to connect. There’s currently nothing blocking any connections there.

I got rid of the xmpp.mydomain.com completely, as it was just complicating things, really. My SRV records now read:

_xmpp-client._tcp.mydomain.com SRV 0 5 5222 mydomain.com

_xmpp-server._tcp.mydomain.com SRV 0 5 5269 mydomain.com

_jabber._tcp.mydomain.com SRV 0 5 5222 mydomain.com

My XMPP Domain Name and Server Host Name are both mydomain.com.

I tried using the IP of the server and wasn’t able to connect, either.

You don’t need that _jabber record. Modern clients look for _xmpp-client.

So, now both XMPP Domain Name and Server Host Name (FQDN) are the same? mydomain**.com**

What client do you use and what error does it give? You can try logging into igniterealtime.org (with random user/password, as public account creation is disabled) and it should give a “wrong user or password” error. Openfire here has such records (pointing to xmpp.igniterealtime.org host serving the server): Check DNS SRV records for XMPP

When using IP to login, you still need to provide the real domain and IP should go into host setting. If you are doing this, is it showing the same error? is your client generating some logs?