powered by Jive Software

Can't Connect to Openfire

I have an issue where I am unable to connect to my openfire sever, which is running on my main machine.

I am able to connect to this using smack on my laptop, but only if it is in the same local network as the machine running openfire.

In this case I connect using the server machines local I.P, such as 192.168.1.5.

However when my laptop is not in this local network I am unable to connect to my server.

I have tried using the external I.P that my server machine uses but this isn’t working.

I have checked on this site

http://www.yougetsignal.com/tools/open-ports/

where you can put in an I.P address and a port number and it tells you if its open or not.

I did try this with the external I.P address that my server machine uses and port 5222, put I am told that it isn’t open. Could this be the problem? I’m not sure how to correct this if it is.

So any advice on how to fix this?

Thanks.

Hi,

Your machine is behind some sort of network address translation device? Does it have the necessary port forwarding setup?

daryl

By that do you mean a router? As currently my machine is connected to one.

I have tried to set up port forwarding on it but it doesn’t seem to work

For example I have forwarded ports 9090 and 9091 which means that I am able to access the admin console remotely, i.e not in the same local network as the server machine.

However when I try doing the same thing but using port 5222 instead it doesnt seem to work.

Any ideas why?

Thanks again

I.

edit Just to be sure, I should be using TCP when setting up the redirect, yes?

Ok I got it working now, and I’m not sure how.

I basically went through the exact steps as I had before, odd.

But thanks anyway.

I.