Can't connect to server in spark plz help

I have install Openfire 3.9.3 on my dedicated server OS centos7.1 and PostgreSQL database.

Openfire install successfully.

and working fine.

but when i try to connect spark IM client to username and pass from openfire server it show

“Can’t connect to server: invalid name or server not reachable”.

Please help me what the prblm with my openfire server ?

Thanks in advance

There could be many reasons. Firewall on the server, the name of the server is not recognized in your network (dns). You can try logging in by using server’s IP address.

Server Directory:
/opt/openfire
Server Name:
62.210.244.78

i have not using domain name.

domain name is required for openfire ?

Domain name is not required for login. You should be able to login using just IP address, but it is better to have a domain name and login with it. If you can’t even login with IP address, then i would check firewall and selinux settings on the server. Try disabling firewall and selinux for a test.

SELINUX=disabled

is disabled i have checked.

http://62.210.244.78:9090

working openfire no issue also i can login admin panel.

i create user in openfire for connect to spark IM client

issue when we try to connect from Spark IM client not connected.

how i can find the issue.

there is any way to check the 5222 port is working or not ?

there is any way to check the 5222 port is working or not ?

You can try telneting this port. You can also run a netstat on the server and see if it is listening on this port.

I believe centos 7 uses firewalld instead of iptables, and is enabled by default. Youll need to disable it. or create firewall rules to allows the traffic.

firewall-cmd --permanent --zone=public --add-port=9090/tcp

firewall-cmd --permanent --zone=public --add-port=9091/tcp

firewall-cmd --reload

i added this

i have check not responding.

those ports are for the web admin console…you’ll need allow 5222 as well, which is used for the xmpp client (spark).

firewall-cmd --permanent --zone=public --add-port=5222/tcp

thank you bro

for great help.

thank you bro