powered by Jive Software

Can't get openfire to install as a service

I’ve installed Openfire on a Windows Server so that I can use the Spark IM program.

I installed it as an administrator. The program works fine until I log off the server, then the serivce stops completely. The only way to get it going again is to do another installation. This is getting ridiculous having to do this several times a week.

I opened a command prompt and went to c:\program files (x86)\openfire\bin

I ran the command: openfire-service /install

and I get the error: Could not open SCManager

I ran the command: openfire-service /start

and I get hte error: Could not start service. Error code: 1060

Can someone help me figure out how to set this up?

try running the command prompt “as administrator” or disable UAC

1 Like

Thank you Speedy. Changing the UAC requires a reboot and I couldn’t do anyting yesterday because it would have kicked eveyrone off. They have come to depend on this program.

This morning I rebooted the server. Ran the install again. Then ran the command lines. Logged off the server and my Spark application on my desktop died. Ugh. So I logged back on the server, went to Services and now see Openfire there. I started the service and within a minute Spark on my desktop started up. I logged off the server and the Spark stays open.

Problem resolved! Thank you!