powered by Jive Software

Can't install openfire in Ubuntu 10.04 Lucid Lynx, obsolete depencies


#1

Openfire 3.6.4 pre-depends on either sun-java5-jre or sun-java6-jre, but neither is available on Ubuntu (server) 10.04, instead there is afaik only 2 package that provides java: default-jre or default-jre-headless… So we need to get this one resolved…


#2

1. Modify your /etc/apt/sources.list file and add the following package repositry:

Partner repository

deb http://archive.canonical.com/ lucid partner

2. Update the package database:

apt-get update
apt-get upgrade

3. Install Java:

apt-get install sun-java6-jre


#3

WEll I’m actually resolved this by modifying openfire’s .deb .control file to depend on “default-jre | default-jre-headless”… I know now that from partner repo one could install sun.java6-jre, but it’s still kinda obsolete, ubuntu usess OpenJDK per default now, and it’s ultimately easy fix… AFAIK I’m somewhat certain this default-jre has been there even before, it allways links to a java runtime that is being used no matter what it is at any given time, so default-jre and default-jre-headless is plenty enough for, if not past, for present use in ubuntu at least (don’t know how other distros handles this…


#4

Probably same as OF-367