powered by Jive Software

Can't install Openfire on CentOS 6.4

Hi,

I am trying to install Openfire on my CentOS 6.4 Server so that it can host a chat service and have tried to follow the following instructions:

http://www.howtoforge.com/how-to-set-up-an-openfire-instant-messaging-server-on- centos-5.6

The trouble is I am falling down at the first hurdle, the instructions tell me to run this command:

rpm -Uvh openfire-3.7.0-1.i386.rpm

but I have checked and the newest version of openfire according to their site is 3.8.2 so I tried this command instead:

rpm -Uvh openfire-3.8.2-1.i386.rpm

all I get is the following message back:

error: open of openfire-3.8.2-1.i386.rpm failed: No such file or directory

Where am I going wrong?

Thanks,

alamb200

As an update I have got Openfire installed now but I cannot get it to start. I know it runs on Java so I checked that it was on, here is the output:

[root@squid alamb200]# java -version

java version “1.7.0_45”

OpenJDK Runtime Environment (rhel-2.4.3.4.el6_5-x86_64 u45-b15)

OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

I then tried to look in the log files of openfire to see if there was anything to learn there so I went to /opt/openfire/logs and tried to tail nohup.out. The result are below:

[root@squid logs]# tail nohup.out

nohup: failed to run command `/opt/openfire/jre/bin/java’: No such file or directory

Can anyone help?

Thanks,

alamb200

How are you attempting to start openfire? via the ‘service openfire start’ command?

CentOS 6.x changed locations and such of some things, so existing rpm files may or may not work unfortunately. I get the same error on my 64 bit CentOS 6.4 boxes. (I believe it means it cannot find your java install)

I typically don’t use the rpm myself, instead opting for the tar.gz and a “manual” install, which ends up using your system’s jvm just fine.

You can try installing the 32bit java on your server (you probably have the 64bit version now) from either openjdk (if available) or Oracle’s Java. Or, if you use the tar.gz, it will take some manual work, but if you read through the guides it’s pretty straight forward.

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install- guide.html

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/database .html

Hi All,

I have got this sorted now the answer was posted by Gary and involved adding the 32bit java installation:

Thanks for your help and I hope this helps someone else.