Can't join MultiUserChat -> remote-server-not-found(404)


I’ve just installed Openfire (latest version) on my debian server. Creating accounts worked fine and I am able to login.

But when I try to join a MUC on a different server, I will get an error: remote-server-not-found(404). I’ve tested three different MUC on different servers:

MUC on -> 404

MUC on private server -> 404

MUC on my server -> works fine

The room itself is available and I am able to enter it with a different account.

The only thing I found about this problem is an 4 year old thread, that says something about server-to-server communication, but if I check the settings, everything is on “allow” at the server-to-server settings.

so, what am I doing wrong?

You have to have an established server to server session, nit just allow settings in there. So, probably you will have to add another servers into your whitelist and then check sessions page for server sessions. Some servers won’t let connection without ssl certificates and secured connection.

So I’ve added the private server of my friend to the white list

But the sessions page for server sessions is empty and I am still not able to connect.

Has he added your server too? What are the security settings for server to server connections on both servers?

Well, no he has not. But I may be able to get him to add my server, but how am I supposed to get my server on the like of big servers like

Well, if this big server is letting Anyone to connect via server to server, then you should be able to connect. In theory. Btw, you friend maybe can also enable it for Anyone, not just for you. So you would check if it is working with that setting. Also this depends on certificates. Check Server Settings > Security Settings. If that big server has a Required option for Server Connections and also doesn’t accept self-signed certificates and if you don’t have certificates intalled of they are self-signed, then i think you won’t be able to connect. Well, this big server may be using other server software (not Openfire), but it can have same policies.