powered by Jive Software

Can''t Login from outside the Class C network?

Can someone tell me why I can’'t login to the wildfire server with spark from outside of my network?

I’'m running the wildfire server on a XP Pro machine with SP2 and all security updates.

I have the corporate checkpoint firewall open on 5222 and 5223 to the wildfire server and outgoing from the server, (but I did try with ALL ports open).

A netstat -a command reveals that there are connections to 5222 and 5223 from inside the network and the ports are open and Listening.

NAT is set up correctly but I can not ping, or connect with spark. I can see the traffic being allowed through the checkpoint firewall, but the client always gets the error (can not connect to server, invalid name or server not reachable).

I’'ve tried connecting with both the FQDN and the IP… both are unsuccessful.

Additionally I’‘ve added the 5222 & 5223 to the windows firewall exceptions list for TCP and UDP even though the windows firewall is disabled. And on the client end I’‘ve added the same port settings to the exceptions list in the windows firewall. I’'m running out of things to try here, what am I missing?

Message was edited by: kaution

I don’‘t know what the deal is but I installed the server with the identical settings in a windows 2003 server environment and I am able to access it from outside the network with a dial up connection. I’'m just going to switch over to that server.


you can always try to connect using “telnet servername 5222” and enter then “” - this should return a stream error if you are able to connect. It would help a lot to know if the TCP connection is possible (you don’'t need UDP).

If it is please post your server name and IP address and the log entries which are written when you try to connect.

You may of course replace IP and xmpp.domainname with fake values.


I did try to telnet. Started the Telnet service and tested from a dialup. “connection refused”.

I’‘ve given up on it. This was a test box anyway. I’'ve installed the server to a production server and it works great on a windows 2003 OS. Thanks for the suggestion.


just a note, “telnet” is a client program and normally connects to port 23 (this is the port of the telnet service). If you add 5222 as port number then you don’‘t need to start the telnet service and I can’'t recommend to start it anyway.


Thanks, I did try to telnet to port 5222 and 5223. Both were unsuccessful on the windows XP machine.