powered by Jive Software

Can't login to admin console after install, stop, start and reboot


#1

Hi

I can’t log in to the admin console on openfire 3.6.4. I’ve tried stopping and starting the openfire server, as well as rebooting my machine.

Does anyone have any other ideas ?

Any help much appreciated

P.s. i’m running windows 7 64 bit


#2

This is probably a bug, affects linux version 3.6.4 too. You have to edit openfire.xml file (don’t know where it is on windows, probably inside openfire/conf dir) and add text marked with red:

*** admin *** 9090 9091

Then restart openfire and you should login as admin with your password (password is admin if setup was skipped).

Big thanks to mr. Oxymoron for this post: http://www.igniterealtime.org/community/message/179404#179404


#3

I had the same problem as OP

I’ve added admin to the openfire.xml file --> now the admin console page cannot be displayed

If I change back to false the admin console comes back, but my configuration is (of course) gone

I’m really finding Openfire difficult to configure. Originally I wanted to authenticate against AD but after a few hours of struggling with “Base DN” and AD attribute names I’ve gone for something less ambitious. Is there a helpful “howto” which would walk me through getting something up and running?

Cheers

Matt

p.s. version 3.6.4 of Openfire running on WIndows Server 2003 SP2

p.p.s Have tried again and now get errors in the Openfire console, see attached textfile
openfire.txt.zip (872 Bytes)


#4

Setting up openfire to use AD is very simple, as long as your structure is well planned out. http://www.igniterealtime.org/community/docs/DOC-1554


#5

Is the firewall allowing openfire to pass?

Are you running it as a service or the gui app?

If the gui app are there any errors in the window?


#6

your error said, that the database is used by other proces, is openfire server up?may be you should take alook at task manager and shut it down (the db) manually


#7

I also have same problem, but i just change my config (openfire.xml) form “true” to false, and start the setup from beginig, and it work again… just fine…


#8

The addition of the … to my openfire.xml fixed my problem. Thanks for the help!


#9

I had the same issue.

Would not let me log into the admin console.

looked at the settings int the db.

They were fine.

set the config file setting for setup to false.

ran through the configuration again with the settings.

I can now login to the admin console.

there is a bug somewhere.


#10

This changing the .xml file did worked for me and I am able to login again. Thanks for the fix.


#11

Had the same problem, when running Openfire as a service under W2K3.

My workaround: stoped the service and started the admin console from the menue (with windows admin-account), then I was able to login…


#12

I had the same problem. I fixed it by editing the database.

See my complete guide to install Openfire at http://www.expertcore.org/viewtopic.php?f=74&t=1851