powered by Jive Software

Can't login to sparkweb - 3.9.2

New install of 3.9.2 and when I put Sparkweb on my webserver and try to login to it the page refreshes and nothing happens.

The logs show.

2014.05.03 21:58:57 org.jivesoftware.openfire.net.StanzaHandler - Closing session due to invalid_namespace in stream header. Namespace: http://www.jabber.com/streams/flash. Connection: org.jivesoftware.openfire.nio.NIOConnection@1316347 MINA Session: (SOCKET, R: /REMOVED:56704, L: /REMOVED:5222, S: 0.0.0.0/0.0.0.0:5222)

I’m confused about this one.

hate to say this but I have the same issue after upgrading also

external clients work fine

let me know what logs you need

2014.05.14 07:43:09 org.jivesoftware.openfire.net.StanzaHandler - Closing session due to invalid_namespace in stream header. Namespace: http://www.jabber.com/streams/flash. Connection: org.jivesoftware.openfire.nio.NIOConnection@cc1f62 MINA Session: (SOCKET, R: /192.168.85.19:1665, L: /192.168.85.11:5222, S: 0.0.0.0/0.0.0.0:5222)

iptables - disabled

on cent os 6.5

ps: Jason is confused about this one - I am just plain old confused

Me too, w/ 3.9.3 as well. Please advise.

Not sure which change has caused this. Have filed as https://igniterealtime.org/issues/browse/OF-806

1 Like

I did downgradde to 3.9.1 and working perfectly

I’ve introduced this, because Openfire was not XMPP compliant in this point and there are efforts to make it compliant (see OF-630).

See http://xmpp.org/rfcs/rfc6120.html#streams-ns-stream

I’ve never heard, that Flash clients are not compatible with the XMPP spec.

ejabbered obviously had the same problem: http://www.ejabberd.im/node/4083

I’ve fixed it by adding another check for the Flash namespace. Now, only if the namespace is neither “http://etherx.jabber.org/streams”, nor “http://www.jabber.com/streams/flash”, the stream is closed.

You may want to review the fix:

https://github.com/igniterealtime/Openfire/commit/da8b960bbe3e51e1019ae46d117a91 d5b6e40a53

I haven’t tested it with a Flash client, but this fix should work. Maybe someone can test it with the next nightly build.

1 Like

Same problem in 3.9.3

Hello I’m newbie of Sparkweb. I do not pass on the step login menu. When I given a username and password always back in to login menu. I am using openfire 9.3.3. can anyone help me?

It will be fixed for 3.9.4 (OF-806). One can use a nightly build until it is released

http://bamboo.igniterealtime.org/browse/OPENFIRE-NIGHTLYWINDOWS-1342/artifact/sh ared/Project-Windows-distribution-files/

1 Like

Hi All, I seem to having the same issue as Sarah.

Sarah wrote:

Hello I’m newbie of Sparkweb. I do not pass on the step login menu. When I given a username and password always back in to login menu. I am using openfire 9.3.3. can anyone help me?

I opened up fiddler and it seems to get a 404 error when trying to load /assets/css/SparkWebSkin.swf

some help would really be appreciated

Read the previous message. Nothing can be done with 3.9.2/3.9.3 version. Either wait for 3.9.4, use nightly build or downgrade to 3.9.1.

2 Likes

wroot wrote:

Read the previous message. Nothing can be done with 3.9.2/3.9.3 version. Either wait for 3.9.4, use nightly build or downgrade to 3.9.1.

Thanks wroot, I tired the nightly version. it fixed my issue with Sparkweb.

but im not longer to get to the adminportal :9090.

Would any of you know from where I can get a 3.9.1 build please.

Thank you

https://igniterealtime.org/downloads/download-landing.jsp?file=openfire/openfire _3_9_1.exe

1 Like

wroot wrote:

https://igniterealtime.org/downloads/download-landing.jsp?file=openfire/openfire _3_9_1.exe

Thank you wr00t - this fixed my issue.

Is this issue also present in 3.9.3 ? I can’t seem to get signed in to my client either. Kind of new at setting this up so I’m not sure where to go to check the logs.

Thanks,

Ddraig

Yes, it is still present in 3.9.3. As OF-806 stays, it fixes for 3.10.0, which is not released yet. You can either go back to 3.9.1 or try latest 3.10.0 nghtly builds http://bamboo.igniterealtime.org/artifact/OPENFIRE-NIGHTLYWINDOWS/shared/build-1 406/Project-Windows-distribution-files/openfire_3_10_0_alpha.exe

Thanks wroot!

I tried installing the debian version of 3.10 on linux but for some reason I can’t get it working. Just won’t load the web interface for some reason.

Ddraig

Well, i can only test Windows build and it works fine.

Hey Owen - I think you are having the same issue I had with the nightly build.

My Current setup is 3.9.1 (installed on server 2012)and sparkweb 0.9.0 (on IIS) everything on one Box and confirm everything works fine.