powered by Jive Software

Can''t make Wildfire run as service in FC3

I follow the installation instruction to install and to get wildfire run as service. The installation is ok, I put wildfire dir under /opt. Then I turn to root and run redhat-postinstall.sh script. It create new user jive, put wirefired to /etc/init.d and create link to that file in /etc/rc3.d/. That’‘s look fine and wildfired service should automatic run when machine bootup but it’'s not.

I must go start it manually by “/opt/wildfire/bin/wildfire start”

notice that when I run “wildfire start” manually it will not return me a shell

My box is Fedora Core3+jdk1.5.0_06

Help me please. Thanks in advance

The first think I would check is make sure the script is turned ON. Do this with :

  1. chkconf --list wildfired

wildfired 0:off 1:off 2:on 3:on 4:on 5:on 6:off

It must read “2:on”, “3:on”, and at least “5:on” in the output. Also notice I have a “d” (for daemon) after the wildfire name. This is the real name of the script unless it was wrong in an older version.

If the script is not on, turn it on with:

  1. chkconf --level 2345 wildfire on

As for manually starting it, I think you are getting you shell back, it is just printing something to the screen after your prompt is printed so it looks like the shell is waiting. Just press enter to get the shell prompt

Opps, one small point, the command is chkconfig not chkconf.

Welcome Ron,

you have the option to edit your posts if they contain errors, it usually looks better than posting a follow-up

LG

Thanks karvin, you right, look like it print "nohup: appending output to ‘‘nohup.out’’(nohup.out is blank) after return a shell but chkconfig result is look OK. It should start on runlevel 2,3,4,5.

chkconfig --list wildfired

wildfired 0:off 1:off 2:on 3:on 4:on 5:on 6:off

my boot.log say wildfire is start ok but when i nmap it’'s no port 9090 open.???

grep wildfire /var/log/boot.log

May 2 11:11:54 fedev rc: Starting wildfired: succeeded

May 2 11:21:23 fedev rc: Starting wildfired: succeeded

May 2 12:36:10 fedev rc: Starting wildfired: succeeded

May 2 13:39:52 fedev rc: Starting wildfired: succeeded

May 2 14:21:29 fedev rc: Starting wildfired: succeeded

May 2 14:56:52 fedev rc: Starting wildfired: succeeded

May 3 09:34:09 fedev rc: Starting wildfired: succeeded

May 3 10:09:04 fedev rc: Starting wildfired: succeeded

nmap 192.168.1.117

Starting nmap 3.70 ( http://www.insecure.org/nmap/ ) at 2006-05-03 10:22 ICT

Interesting ports on 192.168.1.117:

(The 1654 ports scanned but not shown below are in state: closed)

PORT STATE SERVICE

21/tcp open ftp

22/tcp open ssh

23/tcp open telnet

111/tcp open rpcbind

8009/tcp open ajp13

8080/tcp open http-proxy

Nmap run completed – 1 IP address (1 host up) scanned in 0.598 seconds

Hi,

If you did run Wifi as root and not as jive one time you should stop Wifi and run the redhat-postinstall.sh again to make sure that the permissions are right. Otherwise Wifi may not be able to open the log files etc.

No? Then I assume that your wildfired is stored as /etc/init.d/wildfired ?

Could you check if it is there and try to start / stop Wifi being root using it instead of /opt/wildfire/bin/wildfire ?

Maybe the “su” command fails, it you can’'t start it try to run “sh -x /etc/init.d/wildfired”, this could give you more useful output of what the script is doing.

LG

I run “/opt/wildfire/bin/wildfire start” as jive so I think there is no permission problem(already check all log file in /opt/wildfire/logs/ are own by jive).

here is result of “sh +x /etc/init.d/wildfired start”

sh -x /etc/init.d/wildfired start

  • export WILDFIRE_USER=jive

  • WILDFIRE_USER=jive

  • ‘’[’’ ‘’!’’ ‘’]’’

  • ‘’[’’ -d /opt/wildfire ‘’]’’

  • WILDFIRE_HOME=/opt/wildfire

  • case “$1” in

  • start

  • execCommand start

++ pwd

  • OLD_PWD=/root

  • cd /opt/wildfire/bin

  • CMD=’’./wildfire start’’

  • su -c ‘’./wildfildfire start’’ jive

  • cd /root

  • exit 0

Starting wildfire

nohup: appending output to nohup.out’’ <<—need to press enter here to get shell back

Hi,

what do you see in nohup.out if you start it as root using “/etc/init.d/wildfired start”? There are no errors, the “su” command seems to work fine, but I’'m not sure if it does as the username should imho be before “-c command”.

You could try as root:

cd /opt/wildfire/bin && su jive -c ‘’./wildfildfire start’’

and if this works edit the su command in the wildfired script.

LG

Hi it2000,

nohup.out is just a blank file. I think the startup script is work fine becuase I can run it manually by type(as root)

“/etc/init.d/wildfired start” and wildfire will startup perfectly.

or

“/opt/wildfire/bin/wildfire start” as jive

my problem is when it start as service(in /etc/rc3.d/) look like it startup ok but it’'s not.

Starting wildfire

nohup: appending output to nohup.out’’ <<—need to press enter here to get shell back

FWIW, you don’‘t need to press enter to truly get a shell back. You are still sitting at a command prompt, you just had the “Starting wildfire” and “nohup: …” stuff get outputted over it, but your input will still work just as if it hadn’'t happened. Hitting enter just redisplays a new command prompt.

Not that any of this is a big deal. I pretty much reflexively hit enter to redisplay the command prompt myself, even while knowing that its not really necessary. shrug

The joys of standard input and standard output (and standard error, fwiw) being different file descriptors.

Jeff

thanks jmcadams

For now, i remove wildfire service in all run level and start it by crontab.

@reboot /opt/wildfire/bin/wildfire start”

Any opinion still welcome.

Hi, did you try

You could try as root:

cd /opt/wildfire/bin && su jive -c ‘’./wildfildfire start’’

and if this works edit the su command in the wildfired script[/i]. ?

The difference is that you don’'t use the jive environment but the root environment with this su command.

LG

it2000,

I try

cd /opt/wildfire/bin && su jive -c ‘’./wildfildfire start’’

as root and it work ok, wildfire start.

so I edit “/etc/init.d/wildfire” from

su -c “$CMD” $WILDFIRE_USER &

to

su $WILDFIRE_USER -c “$CMD” &

but it give me the same thing. wildfire service is not start

pbp

This is what works for Mandrake

#!/bin/sh

  1. description: Wildfire is a java based jabber server

  2. chkconfig: 2345 99 00

case “$1” in

‘‘start’’)

/opt/wildfire/bin/./wildfire start

touch /var/lock/subsys/wildfire

;;

‘‘stop’’)

/opt/wildfire/bin/./wildfire stop

rm -f /var/lock/subsys/wildfire

;;

*)

echo “Usage: $0 { start | stop }”

;;

esac

exit 0

Hi,

I try to automaticaly start wildfire as a service in FC5, but I have the same problem…

When Selinux is Permissive it work!!!

I don’‘t understand why wildfire don’'t start when Selinux is enforcing.

In /var/log/secure …

su: pam_unix(su:auth): auth could not identify password for

Have someone any ideea about why happen that ?

All problems come from su auth with Selinux Enforcing… Because the jive account has no password…

What somebody suggest? Please help!!!

Hi,

I did grab a FC5 version and set a password for jive, this does not solve the problem. The file to edit for the other interested users is “/etc/selinux/config” and one may modify “SELINUX=enforcing” to “SELINUX=permissive” or “SELINUX=disabled” to get this solved and be aware of the impact his has on the system, if any.

LG

Yes, but I like to run it as root… Selinux is useful, and wildfire is in java anyway…

Hi,

running a service as root is never a good idea.

If you want to run it as root anyhow you don’'t need the "su - jive " entry, so where is the problem?

LG