Can't Reach server + Configurations reset after server restart


I’ve installed Openfire 3.9.3 on OpenSUSE 13.2 (x64) through RPM (as the installation guide recommends), without installing the Oracle/Sun JRE (cause it says RPM installer comes with a native JRE pack). It works fine and server is up, but clients can’t reach it (tried with both Psi and Spark). I was able to ping the server IP from a Windows machine in the same LAN, but couldn’t ping the hostname.

The server is up and running right now, but it crashed two times already when I restart the service, can’t figure out why.

I used “exit” to leave the java execution and then /opt/openfire/bin/ to start again. I tried to login but it showed the setup wizard again and when I clicked next, it showed a HTTP 500 error javanullpointerexception. Don’t have the logs right now cause it seems to be working fine now, but it may happen again when I reboot the machine tomorrow.

This is the first time I setup a server of anything in my life, and like the second time I work with Linux, so if you guys could be very specific (like i’m a complete retard, which in this case I am) I would be really grateful.

Thanks for the attention and patience.