powered by Jive Software

CentOs 5.3 VPS installation issues w/RPMs

I’m trying to install Openfire on a CentOS 5.3 VPS server w/384Mbytes RAM.

Since it’s CentOs, I decided, against my better judgement, to follow the RPM installation instructions from the install docs here.

rpm -ivh openfire-3.6.4-1.i386.rpm

Then I did a ‘java -version’, and it appeared the Java was not installed, so I d/l’d the JRE from Sun and did an rpm install of that too.

./jre-6u17-linux-i586-rpm.bin

Then I attempted to start Openfire.

/etc/rc.d/init.d/openfire start

Error: JAVA_HOME is not defined correctly.
Can not sure execute /usr/local/jdk/bin/java

Then I did a 'java -version and got the following error:

java -version

Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.

Okay, now, how/where do I put the -Xms32M -Xmx128M (or similar) params in so I can check Java? And I’m assuming that I’m going to need to do this in /etc/rc.d/init.d/openfire too, or one of the other files associated with Openfire startup scripts, and what would be the exact syntax, not withstanding the ranges of RAM?

Thanks,

Bradley.

Okay I edited /etc/sysconfig/openfire to the following:

================================

Set this to the path where openfire lives.

If this is not set the script will look for /usr/local/openfire, then

/opt/openfire.

#OPENFIRE_HOME=""

If there is a different user you would like to run openfire as,

change the following line.

#OPENFIRE_USER=“daemon”

If you wish to change the location of the openfire pid file,

change the following line.

#OPENFIRE_PIDFILE="/var/run/openfire.pid"

If you wish to explictly specific the location of the log directory,

you can set it here. Note that this applies to the logs generated outside

openfire itself. If you want to change the location of openfire’s own

logs, see the system property ‘log.directory’. If this is not set,

it will default to $OPENFIRE_HOME/logs.

#OPENFIRE_LOGDIR="/some/where/logs"

If you wish to set any specific options to pass to the JVM, you can

set them with the following variable.

#OPENFIRE_OPTS="-Xmx1024m"

OPENFIRE_OPTS=“Xmx256m”

If you wish to override the auto-detected JAVA_HOME variable, uncomment

and change the following line.

#JAVA_HOME=/usr/java/default

JAVA_HOME=/user/java/default

====================================

Now I’m getting the following error:

/etc/rc.d/init.d/openfire

Error: JAVA_HOME is not defined correctly.
Can not sure execute /user/java/default/bin/java.

but my /usr/java/jre1.6.0_17/bin/java (/user/java/default/bin/java and /user/java/latest/bin/java) is chmod’d to the following:

-rwxr-xr-x 1 root root 47308 Oct 11 21:35 java*

Okay I changed the last line in /etc/sysconfig/openfire to the following, and the daemon seems to have started up.

JAVA_HOME=/opt/openfire/jre

I don’t know why I had to do it this way, but I’m sure going to just going to install from tarballs next time, compiling or whatever. I hate rpms, and by the looks of it, it would have been easier and more straightforward (and smaller) anyway.

Now I’m going to play with the RAM parameters. I’ve got it set to 256 Megs right now, but I’m supposed to have burstable RAM up to a gig so let’s see if I can just let her fly with what she wants. I won’t bother reporting that here, as YMMV

Here’s a couple of links that provided me with the hints I used to arrive at this immediate solution:

http://www.igniterealtime.org/community/message/148265

http://ubuntu-unleashed.blogspot.com/search/label/Install%20Jabber%20Server%20on %20Ubuntu

My recommendation, being a slackster anyway, is to get the tarballs, put everything where you want it, and if neccessary compile from scratch. After I play with Openfire for a bit, I’m going to do a Slack64 install and then prolly create a Slackbuild and post a link to it here for anyone who wants a fast, no frills install for Slackware, along with some config adjustment recommendations, etc.

Hope this help the next person

Kindest regards,

Bradley

.