Certificate Page Problem


java.lang.StringIndexOutOfBoundsException: String index out of range: 0
     at java.lang.String.charAt(Unknown Source)
     at org.bouncycastle.asn1.x509.X509Name.(Unknown Source)
     at org.bouncycastle.jce.X509Principal.(Unknown Source)
     at org.bouncycastle.jce.provider.X509CertificateObject.getIssuerDN(Unknown Source)
     at org.jivesoftware.util.CertificateManager.isSigningRequestPending(CertificateManager.java:341)
     at org.jivesoftware.openfire.admin.ssl_002dcertificates_jsp._jspService(ssl_002dcertificates_jsp.java:542)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
     at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:42)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:99)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
     at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
     at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
     at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
     at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
     at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
     at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
     at org.mortbay.jetty.Server.handle(Server.java:324)
     at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
     at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
     at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
     at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
     at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
     at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
     at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

How do you fix this?

33 views and no idea of an answer?

No idea, but perhaps it could help if you describe as exactly as possible what you tried to do as you got this exception. Also you could tag it as “bug_report”, so one of the developers will look at this.

I clicked on the server certificate link in the server properties page.

Dont know how to add a tag.

are you trying to use the openfire self-generated certificates or did you purchase certificates? Is this a new install? Please provide as much detail as possible.

>are you trying to use

the openfire self-generated certificates or did you purchase


I’m trying to get in to certificates to set up a cert/cert request to our CA

>Is this a new install? Please provide as much detail as


I’m not sure what you mean by that… It is relatively new, but its been running for at least 2 weeks.

Details please…

Server OS

Number of users

In product or just in testing phase

Embedded database or External

Have you tried a re-install

This is not a case where less is more. The more data you provide the better somebody may be able to help.

Server OS: centos 4.5

Number of users: next to none - test deployment phase

Embedded database or External: mysql

Have you tried a re-install: its a test production server, that is a last resort…

ask the questions and i will provide info unless it should be kept private. - its not that i dont want to give you the information, its that i dont know what you need / what would help.

Well the good thing is that you can do a re-install with little to no loss of data since you are using an external database. You would need only backup the openfire.xml, and edit it so the setup tag reads . Reinstall openfire copy back the openfire.xml and walk through the config again. most of the data will be filled in by default.

Before you do this though you could just delete the existing certificates from the openfire\resources\security folder.

Great, that still involves taking a live server down, it may still be in testing stages but it is in use. You are telling me there is no way to troubleshoot this issue?

Not without an interuption of service. You either have a permissions issue on the directory structure, corrupt certs, or a bad install in general.

havent been able to do anything with/to the certs… i could get into the page right after i installed, the permissions are a maybe, but that seems like it would be a bigger issue.

i can handle a 2-10 minute downtime, just not 20 minutes to rebuild.