powered by Jive Software

Change standard port 5222 to 80

Hola!

Yo necesito cambiar el puerto estandar 5222 por el 80.

yo tengo el Servidor Spark 3.4.4. Cómo puedo cambiar el puerto 5222 a 80 para el cliente Spark

Gracias.


Hi!

I need change the standard port 5222 to 80.

I have a openfire server 3.4.4. Who i change the port 5222 to 80 for the spark client

Tankyou.

On the “Server information” page in the Openfire interface there is a button at the bottom to “Edit Properties”. There you can modify the default port field. You will also need to modify the port in the client as well (advanced tab on spark).

The other option is to enable and set the HTTP-Binding port to 80 on the HTTP-Binding page in the admin interface which is 8080 by default.

Thanks, your answer was correct, the change to port 80 work fine with local users.

Now, we have another problem: the client need signon to our active directory (the box name is pantera), so, when they try to connect

they received the message: “Invalid user name or password”. Our configuration is

  • In DMZ a box CGRMSG with the openfile (chat service)

  • Inside an active directory PANTERA (a special sub network)

  • Internal user: in another path (other sub network)

  • internet : external employees in others companys.

What other ports or what we need do to work fine using the active directory for authentication?

You will need to allow traffic on TCP port 389 from CGRMSG in the DMZ to the PANTERA on the internal network. Did you setup Directory Server (LDAP) authentication or are you using “Default”?

I install the setup Directory Server (LDAP) authentication.

What happens if you go into “Profile Setting>EditTest Connection”? Do you get a “Success” response?

If not can you telnet to the PANTERA server’s port 389 from the CGRMSG server? - if this fails you have an issue with your firewall rules.

If you can telnet to the port but fail the “test connection” make sure your Base DN and Administrator DN are correct.

If the “test connection” is succesfull then most likely your login name is in the wrong format. Try using just the username (ex. bf2007) and if that fails try using the full jabberid (ex bf2007@yourjabberdomain)

Hi

The change of port 80 work fine. The problem is adjusting, we were configurate the firewall.

Our OpenFire Server was working for 6 months without problem with the port 5222. Today the service is working with the port 80.

But, i have other consult: the Spark client no auto detect the port 80 in the Advanced option called “Automatically discover host and port”. Only the clien Spark work fine if write the port and the server name.

Is posible that the client auto detect the new configuration without write?

Thank!

You would need to configure some SRV records in your DNS servers.

Example entries

; XMPP
_xmpp-server._tcp     3600 IN SRV 10 0 5269 mail.example.com.
_xmpp-server._udp     3600 IN SRV 10 0 5269 mail.example.com.
_xmpp-client._tcp     3600 IN SRV 10 0 5222 mail.example.com.
_xmpp-client._udp     3600 IN SRV 10 0 5222 mail.example.com.
_jabber._tcp          3600 IN SRV 10 0 5269 mail.example.com.
_jabber._udp          3600 IN SRV 10 0 5269 mail.example.com.
_jabber-client._tcp   3600 IN SRV 10 0 5222 mail.example.com.
_jabber-client._udp   3600 IN SRV 10 0 5222 mail.example.com.

/code

Hi!

I did the configuration the SRV records in our DNS server, but the spark client is not detecting the new configuration with the port 80. The Spark work fine if I write the port 80 and the name server. The question is if exist other configuration to do it?

Also, when I connect the computer in Internet, the client receive and send text messages, but the computer to computer communication, no work fine. This work fine only on the Intranet. What configuration need its?

Thanks!

Did you set the ports to “80” instead of “5222” in the SRV entries?

If you run

nslookup -type=SRV _xmpp-client._tcp.yourdomain.name

Do you get something like this but with port 80 instead of 5222

Non-authoritative answer:
_xmpp-client._tcp.gmail.com     SRV service location:
priority       = 20
weight         = 0
port           = 5222
svr hostname   = talk3.l.google.com
_xmpp-client._tcp.gmail.com     SRV service location:
priority       = 20
weight         = 0
port           = 5222
svr hostname   = talk4.l.google.com
_xmpp-client._tcp.gmail.com     SRV service location:
priority       = 5
weight         = 0
port           = 5222
svr hostname   = talk.l.google.com
_xmpp-client._tcp.gmail.com     SRV service location:
priority       = 20
weight         = 0
port           = 5222
svr hostname   = talk1.l.google.com
_xmpp-client._tcp.gmail.com     SRV service location:
priority       = 20
weight         = 0
port           = 5222
svr hostname   = talk2.l.google.com talk3.l.google.com      internet address = 216.239.51.125
talk4.l.google.com      internet address = 209.85.163.125
talk.l.google.com       internet address = 216.239.51.125
talk1.l.google.com      internet address = 72.14.253.125
talk2.l.google.com      internet address = 209.85.137.125

For the computer to computer file transfers to work you need to allow traffic on port 7777 to/from your openfire server.

Hi!

This is the result of run the command:`` nslookup -type=SRV xmpp-client.tcp.yourdomain.name

nslookup -type=SRV xmpp-client.tcp.cgr.go.cr
Server: 10.100.1.10
Address: 10.100.1.10#53 xmpp-client.tcp.cgr.go.cr service = 0 100 80 cgrmsg.cgr.go.cr.

Other question: is possibility to change the port 7777 ?

Are the internal end users using 10.100.1.10 as their primary DNS server? Externally the records do not resolve so outside users will not be able automatically pick up the port settings. In order for external users to resolve poperly you will need to updated the records on ns.cgr.go.cr. I tried doing a lookup against your external DNS server (ns.cgr.go.cr) and the record did not resolve properly.

As for port “7777” that can be modified in the openfire admin interface in the “File Transfer Settings” under “Server Settings”