Chatwindow does not appear

We have installed openfire and the plugin fastpath.

If we try to test fastpath, everything works fine until the agent is accepting the request, then no window is opening and the customer do not see the chatwindow…

Does anyone know how to fix this problem?

Kind regards


Tell us versions of both you are using. I remember having problem with OF 3.7.0 Beta

Have a look at

Openfire 3.6.4 and Fastpath Service 4.1.0 and Fastpath Webchat 4.0.0

OK, so you have the same versions as I have now, and it is working for me. As you know Fastpath Webchat uses TCP/5222 for communication once the agent acknowledges. What I think is that you may check if “user” can actually access TCP/5222 from the box they trying to use Fastpath Webchat feature (firewall, access list).

Have you actually tried this feature on local network, or you actually have that issue on local network?

Are any XMPP clients connecting to Openfire with no problem?

First of all sorry for the delay, but I was a little bit bounded in work…

The Problem is, that I try to access the testing appplication directly on the JabberServer. And my client let the traffic go, also my collegue tried and the chat does not appear. We could chat via Spark, but whether in the agent spark window neither for the customer the chat window appears…