powered by Jive Software

Clearspace 2.5


#1

Some notes about Clearspace 2.5:

  1. Is there a way to enable that old editor? I don’t like WYSIWYG editors on web pages, because they are not working in most cases. An other point is that WYSIWYG is much slower to use. Some examples which don’t work here:
  • How to insert source code? {code}-Tag does not longer work, and I don’t find any button for that. 50% of my posts in this community do contain source code…
  • If I copy&paste text, e.g. from a online dictionary, it does create a link of it or does other stupid things like changing the font size.
  1. Why we see now real names instead of the usernames? There are more oddities in the user profile, eg. in my profile I have fields like* *500.5000.1, 500.5001.1 or 500.5011.1. What is this?

  2. In the past it was possible to show only the recent content of some special sub-communities on the start page. Is it still possible to show only recent content of “Openfire Support”, “Openfire Dev” and “Community Plugins” ?


#2

Coolcat i suppose? I havent tried new clearspace version a lot. I see much power in Personalizing. But what i hate the most is the SLOWENESS. I hope this is temporary… And i dont want this wisiwyg either. In PM messages editor is not doing word wrapping.


#3

Coolcat i suppose?
yes.


#4
  1. Why we see now real names instead of the usernames?
    If I want to use the “Watch a User”-Widget I have to specify a username. Yeah…cool…but how to find out the username, since I only see the real name. Seams to be an really ingenious interface… (ok, there is a way: open the users profile and take a look on your address bar, but…my goodness!)

#5
  1. The WYSIWYG has a double >> next to the emoticon button that allows you to insert various types of code.

  2. If you see real names then the person your self include filled in their profile with their real name after the upgrade and chose show below the last name field. If you choose hide your username shows instead.

  3. You ca no longer do this :frowning: . Truly a downside to this new system.


#6
  1. ah…ok…but typing {code} is still much faster than choosing “SyntaxHighlighting -> Java” from that menu. However, you call this “SyntaxHighlighting” ?
public class Test {
     public static void main(String[] args) {
          System.out.println("Hello World.");
     }
}

#7
  1. I ran into a bug:
  • Logout
  • Go to your own Profile
  • Download your own vCard (small icon next to your name on profile page)
  • Login again => page does redirect to vCard download instead of login
  • press refresh button of your browser
  • you are now logged in correctly

#8

Rich text editor is here to stay. Having to dance between the plain text editor and the rich text editor is what caused so many problems with the rich text editor before. (they were using conflicting methods of wanting to store the raw data and such and had to be hacked to cooperate … if you could call it that) The new editor is quite good actually. I never thought I would like a rich text editor but this one actually converted me. I “missed” the macros for a time but got over it.


#9

I don’t see any 500.5011.1 looking things in your profile, where are you seeing that? Would you mind attaching a screen shot?


#10

It is possible to show the recent content of certain subcommunities. What it -can’t- do is combine that into one widget. If you had three, you’d have to have three recent content widgets. Anyway, click on the edit button (in the upper right hand corner) of a widget to change it’s configuration.


#11

Hrm. Watch a user widget requires a username? That’s a good point, if we’re going to have full names in a lot of places, we should have a user searcher thing for that. I’ll report that back to the team. I’m also going to ask around if there’s a way to force user of nicknames. At the moment it’s totally up to the user as to what gets used. In the case of this community, I’d rather see nicknames, and I think everyone would. I’ll see what I can find out, thanks!


#12

Coolcat wrote:

  1. I ran into a bug:
  • Logout
  • Go to your own Profile
  • Download your own vCard (small icon next to your name on profile page)
  • Login again => page does redirect to vCard download instead of login
  • press refresh button of your browser
  • you are now logged in correctly
    Ooh. Great catch. Reporting back. Thanks!

#13

Would you mind attaching a screen shot?
Looks as there would be some strings not available.


#14
  1. Is it possible to disable the build-in spellchecker and get back my browsers spellchecker? (I’m using Firefox)

#15

Coolcat wrote:

Would you mind attaching a screen shot?
Looks as there would be some strings not available.

Whoa what the crap? What language setting do you have? Looking at the exact same page, except from my perspective, I’m seeing the proper fields! Todd? Anyone else? What happens if you look at yours?


#16

Coolcat wrote:

  1. Is it possible to disable the build-in spellchecker and get back my browsers spellchecker? (I’m using Firefox)

I’m quite with you there… I don’t know what’s actually preventing the browser spell checker from doing it’s job. I’ll ask around!


#17

wroot, regarding the speed, the bulk of that is due to initial “having to cache stuff”. It should calm down and be quite speedy. In fact right now everything is running faster than it did under 1.10 for me. Let me know if it keeps being slow.


#18

Whoa what the crap? What language setting do you have?
I see this in all profiles, not only my own. Locale in preferences is set to “German (Germany)”. When setting to “English (United States)” everything looks right.


#19

Coolcat wrote:

Whoa what the crap? What language setting do you have?
I see this in all profiles, not only my own. Locale in preferences is set to “German (Germany)”. When setting to “English (United States)” everything looks right.

Excellent catch! Reporting back!


#20

Let me know if it keeps being slow.
When pressing “Reply” here in this thread it takes 5-6 seconds until I get the editor, if the page is already cached and I have already done some other “Replies”. When clearing the browsers cache before pressing on “Reply” it takes actually 22 seconds until I can start to write.

What about the “SyntaxHighlighting”? (I mentioned it above)