powered by Jive Software

Client cannot log in or create account

I cannot log in with account created through web admin, nor can I “create” a new account.

Admin (9090) works fine.

Get this error message in log:[i]

2006.01.21 01:16:27 org.jivesoftware.wildfire.net.SocketReader.negotiateTLS(SocketReader.java:681)

Error while negotiating TLS

javax.net.ssl.SSLHandshakeException: no cipher suites in common

at com.sun.net.ssl.internal.ssl.Handshaker.checkThrown(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.checkTaskThrown(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.writeAppRecord(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.wrap(Unknown Source)

at javax.net.ssl.SSLEngine.wrap(Unknown Source)

at org.jivesoftware.wildfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:259 )

at org.jivesoftware.wildfire.net.TLSStreamHandler.(TLSStreamHandler.java:14 5)

at org.jivesoftware.wildfire.net.SocketConnection.startTLS(SocketConnection.java:1 50)

at org.jivesoftware.wildfire.net.SocketReader.negotiateTLS(SocketReader.java:678)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:267)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)[/i]

I tried disabling SSL, no effect. Deleted keys, no effect. Made sure client was trying login without security. Tried three different CLIENT programs, then tried SPARK, still can’'t login to existing account (invalid username/password message or very long login attempts) that was created via 9090 admin. Cannot create new account even though admin settings allow new account creation.

I know I am using correct domain name because if I use incorrect name in client then I get a message from client that it cannot find server.

Server is also my gateway/router RH7.3. I am running IPSEC VPN. Perhaps I need to choose other ports?? What ports besides default should I try?

2006.01.21 01:31:08 org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:159) Connection closed before session established

Socket[addr=/192.168.1.106,port=2193,localport=5222][/i]

Server running skeleton RH7.3 perhaps I need to install some other RPM? Wildfire RPM installed via webmin package installer, no dependancy errors were reported.

Hey AnOldMan,

I have never seen a case like this before but after a quick google search I found a possible explanation. The problem may be related in the way you imported your certificates. So I have a couple of questions for you.

  1. Stop the server, restore and use the out of the box keystore and truststore files and try again. Exodus and Spark clients should be able to log in fine.

  2. If step 1 works fine then the problem is with the way you updated your keystore (i.e. how you imported your certificates). Could you give us a step-by-step explaining how you are adding and signing your certificates? My guess is that you deleted the keystore file before importing the signed certificates.

Regards,

– Gato