powered by Jive Software

Client disconnect


#1

My client application seems to disconnect from the openfire server after a certain period of time (looks to be around 10 minutes …i’m debugging it currently) I’m using the latest release 3.7.0 and have read on this forum that this release fixes some problems people were seeing with disconnections but i’m still seeing it happen. I have ‘Do not disconnect clients that are idle’ set in the idle policy settings and also ‘Do not send XMPP Ping requests to idle clients’ is turned off.

Is there anything else i need to do to stop disconnection? As a note, i know that the server is still up and running and my application still has network access so it’s not a network problem or a server unavailable.


#2

Did a bit of debugging. I’m not seeing any message from the server saying anything bad. My user on the client side was in a MUC room at the time and when i go to the openfire admin console i see that the user is still shown and online (green icon) but when i look at the MUC rooms with the Spark client (using browse conference rooms) i see that the number of occupants says N/A (it usually says the correct number) …so now i’m not so sure that it’s a disconnect issue but rather something went wrong with the MUC


#3

I decided to test using the Spark client and i’m seeing the same problem. It seems to be related to a network disconnection/reconnection. I start up Spark, log in, join a MUC room and chat away fine. Then i simulate a network drop by disconnecting the network and then reconnecting it (via WiFi) and from that moment on any message i type into Spark will not be received by OpenFire (messages are shown in light orange color in Spark)

Can anyone suggest a way to handle such a network disconnection in a client? It seems that this would be a common occurrence using a mobile client.

Thanks


#4

i am also having same issue did you get any luck with this ?


#5

Hi, Is there any solutions for this.

Thanks
Mohsin


#6

Which version of Openfire are you using? You may get some mileage by setting the Openfire system property stream.management.active to false

Greg