Clients can connect, but can't see/msg eachother - Ubuntu Server/Openfire (latest)

This is a new build. Just spun up an ubuntu server, installed and went through the config for Openfire.

I chose Oneteam as my client and installed it on two windows 7 workstations. Both can connect using the users i created on the admin control panel. I can see both are connected, but when i add the contact, the status shows the other user offline, and when i try send a message it doesn’t arrive on the other test user.

The simple firewall on ubuntu is inactive, and neither windows machine has the firewall enabled.

I’ve tried using native, http binding, https binding, Old style SSL encryption (not required on server) - every combination i could come up with, mirrored between test machines and disconnected/reconnected after each change and nothing.

Couldn’t find anything on the boards/google about this, i’m hoping i missed an easy step somewhere.

Oh and, i named my server Messager before a google search told me i was an idiot and named my server after a relaxing body rub. So laugh at my expense.

Cheers all

Try some other client (Spark, Psi, Pidgin). Usually in jabber/xmpp one user has to approve another user’s request to add him, before messaging can occur. You can also try creating a group, put those users in that group and then enable sharing of this group to All users (this will make them automatically subscribed to each other). Or you can use Subscription plugin for Openfire and set it to automatically accept subscription requests. Two last options are if you really want to use Oneteam client. Maybe it doesn’t fully support some specs of xmpp and you don’t get subscription requests.

Thanks for the reply. I uninstalled oneteam, and installed spark. Its behaving the same way though…

I didn’t know you had to “approve” adding someone as a friend, but users get no alerts/or msg to accept a friend request. At least on the spark client, it says, “Pending” next to the persons name i add. There is nothing on the other PC client to accept as far as i can see.

Am i missing something? Oh, and you can doubly make fun of me. A google search convinced me i spelled “Messaging” wrong, so i changed the server name, DNS reverselookup records etc… only to find out i was right the first time… had to change them all back. ugh. lol.

Scratch that… I took your other bit of advice and created groups on the servers. They showed up immediately.

Thanks!