powered by Jive Software

Clients can't connect after upgrade to 3.9.1

I just upgraded Openfire from 3.8.1 to 3.9.1 and all of the sudden neither Psi+ or Kopete can connect. Thunderbird chat, on the other side, works.

It looks like some SSL-related problem. I’m using a PositiveSSL certificate that worked prior to upgrading. Can anyone help?

Error on Openfire side:

http://pastebin.com/akeb1sLL

Psi+ XML log:

http://pastebin.com/qweMTdjy

Looks like http://issues.igniterealtime.org/browse/OF-636.

Try to use the Oracle JVM or the previous JRE.

Thank you - this helped.

Hello GDR!, do you have a guide to configure openfire with SSL ? I tried to use rapidssl but i couldn’t configure this with 3.8.1. Now i would like to test this with new version. I don’t know how to proceed with this.

Regards,

You go to Server - Server Settings - Server Certificates - Import, the URL is https://yourserver:9091/import-certificate.jsp

I don’t really remember the whole procedure. It’s described here http://community.igniterealtime.org/docs/DOC-1092 - make sure you read the note about conversion in the bottom