powered by Jive Software

Clustering Issues w/ 3.9.3

Goal: Two clustered OpenFire servers to cover all users at our company’s two primary sites.
Infrastructure: Two networks, routered a third, private network for the long-haul connection. No filtering or firewall between the network

Network A <–> Router 1 <–> Network B <–> Router 2 <–> Network C

Platform: CentOS 6.5 in VMWare (5.5) environment at both locations. Single virtual NIC on both machines, all neworking configured and checked. Even turned off iptables incase I’d missed something there… no luck.

SQL: Using MySQL on both machines configured in a MASTER/MASTER replication, which shold work similar to a single external server (I hope?). Have tested and this is work as expected from the mysql client’s point of view.

Configuration: Figured out quickly that Multicast wasn’t working. I suspect that the Cisco routers (routers 1&2) are not setup to repeat the multicast across the networks. I reconfigured Hazelcast config to disable multicast and enable TCPIP with clauses for each server.

Current Results: Both servers see each other. The first server to be started will see all info about the second server, but the second server will NOT see info about the first. Clients can connect to both servers (both are authenticating against our AD servers at their respective locations), but the clients will not be able to see each other. I’ve tried sending a message from a user on the second server to the first server and nothing went through, but when I reboot that second server, and the user fails-over to the first server (where the other user has been logged in), the message suddenly gets delivered (but only the most recent message).

I have tried every combination I can think of. I dumped the debug log, but didn’t see anything obvious.

Any suggestions would be greatly appreciated!

Don

OK, I noticed that I’m getting the following in my warnings on startup (actually, a few seconds after startup):

2014.07.09 14:57:14 com.jivesoftware.util.cache.ClusteredCacheFactory - No cluster members selected for cluster task org.jivesoftware.openfire.session.GetSessionsCountTask

I have the following in my config:

10.10.1.231:5701

10.10.2.231:5701

The route between the two networks is wide open, as I stated above.

Again, any assistance would be greatly appreciated!