Communicating with a wildfire server in a windows pc

… using an application built with smack in a solaris pc not working (sorry the title can’'t accomodate)

so the title says it all. i’‘m working my application in solaris and plan to run it there. the wildfire server is running on a windows pc. i’‘ve placed the correct ip address and the server name of the windows pc (server) on my application so it could create/login to the server from the solaris pc. the problem is there is no response from the server for some reason. i thought there was a problem with the connection but i tried pinging the solaris pc using the windows pc and the packets were sent without any problems. i can’‘t seem to ping the windows pc using the solaric pc because the ping command doesn’‘t seem to work (i don’‘t know why at all). i tried pinging the windows pc using another windows pc and it worked, so i guess there’‘s no problem in the connection or in the network for that matter. but how come my app can’'t communicate with the server? am i missing something? do i have to turn down the firewall in my windows pc (i prefer not to)?


you must at least open port 5222 on Windows so that the Solaris computer can connect.

Maybe you can limit also the source address for port 5222 on Windows - but I have no idea about Windows and it’'s poor firewall.


well i was already able to make it run. i was able to ping the windows pc using the solaris pc already. and for some reason, after i did that, everything worked fine (the communication between the two pc’'s with different OS).