Compiling Openfire w/ Jetty 7.5.3

I tried compiling Openfire with the most current Jetty release. I could not find a patch for this in SVN, so wasn’t sure if anyone else had fixed it.

[javac] /home/dcoulson/openfire_src/src/java/org/jivesoftware/util/log/util/JettyLog.ja va:31: org.jivesoftware.util.log.util.JettyLog is not abstract and does not override abstract method ignore(java.lang.Throwable) in org.eclipse.jetty.util.log.Logger

[javac] public class JettyLog implements org.eclipse.jetty.util.log.Logger {

[javac]        ^

[javac] Note: Some input files use or override a deprecated API.

[javac] Note: Recompile with -Xlint:deprecation for details.

[javac] Note: Some input files use unchecked or unsafe operations.

[javac] Note: Recompile with -Xlint:unchecked for details.

[javac] 3 errors

[javac] 6 warnings

Anyone have a patch/suggestions how to fix?

Hi David,

I was about to go down that path too, but haven’t gotten that far yet. OF-481 is tracking this



I couldn’t tell from the issue report if it was just a wishlist item, or if someone was activly working on it. Someone else had integrated 7.5.1 with Openfire 3.7.0 to support the WebSockets extension, but they did not release their openfire patch to accomplish this :-/

Thanks David. Guus is in charge of openfire and is the only committer clever enough to do it outside of a patch coming in. I was going to try it and see how much API changes occured with Jetty that require openfire code changes. Simple stuff I can do! I’ll chat with Dele again and see if I can get him to upstream his stuff

Anything to report on this?

hehe, nope. I didn’t persue it any further yet.

Sorry I can’t submit a patch as I am seperated from my PC by 4000

miles until second week of Nov


On 20 Oct 2011, at 16:47, akrherz <

Do you have a patch available? There are some SSL security updates in recent Jetty versions that would be advantagous to get into Openfire.

I am willing to do some testing - Not good enough with Java to build my own patch though :slight_smile:

1 Like

Hi Dele,

Are you back and able to submit something for this?


I will update my build with latest SVN and recompile and try to generate a diff file

I am back, but only for a few hours a week

I have already filed a small patch in OF-499 to update

org.jivesoftware.util.log.util.JettyLog, but that’s easy. What needs to be done is fixing SSL glue code.

Here is a zip file of files that I changed to recompile latest Openfire SVN with latest stable Jetty 7.5.4.

Sorry, I can’t make a diff file

-dele (1459386 Bytes)

Hi Dele, Thanks! I am inclined to commit this to trunk so others can easily test, but will wait to see what Guus says.

Perhaps I did something wrong, but I can’t get the admin console plugin to load

2011.12.29 06:55:37 org.jivesoftware.openfire.container.PluginManager - org.slf4j.spi.LocationAwareLogger.log(Lorg/slf4j/Marker;Ljava/lang/String;ILjav a/lang/String; [Ljava/lang/Object;Ljava/lang/Throwable;)V

java.lang.NoSuchMethodError: org.slf4j.spi.LocationAwareLogger.log(Lorg/slf4j/Marker;Ljava/lang/String;ILjav a/lang/String; [Ljava/lang/Object;Ljava/lang/Throwable;)V

at org.eclipse.jetty.util.log.JettyAwareLogger.log(

at org.eclipse.jetty.util.log.JettyAwareLogger.warn(

at org.eclipse.jetty.util.log.Slf4jLog.warn(

I set my Openfire build target to “Openfire” and copied the entire admin folder in the target folder to replace the old one. You also need to replace the SLFjar file in the Openfire lib folder with the new one.

Thanks, that worked. The only doubt I have left is this log message

2011.12.30 08:30:06 org.eclipse.jetty.server.Server - jetty-7.x.y-SNAPSHOT

Do you get actual version numbers instead of x.y ?

I got that as well :slight_smile: Could be the Jetty jar files I downloaded. Try downloading the files yourself to see if it makes a difference, otherwise I would assume fault is with Jetty team.