Conferences blank in Spark 2.6.3 w/ Openfire 3.7.1

We recently upgraded from Openfire 3.6.4 to 3.7.1 (no intermediate 3.7.0). Our standard Spark install is 2.5.8, however some people have 2.6.3 (and others use Pidgin/Adium, etc).

Upon updating to 3.7.1 users running 2.6.3 could not see any conferences in their client. They could manually join. Users with 2.5.8 could see conferences. I tested a few different releases of Spark and 2.6.0 through to 2.7.0beta didn’t work for me. Pidgin/Adium worked fine. Users with 2.6.3 occasionally reported they could see one chat room in the list, but personally I always saw zero.

I downgraded to 3.7.0, which seems to fix the issue. There were a bunch of MUC changes between 3.7.0 and 3.7.1, but short of backing each out one at a time it’s not obvious to me which broke it, Since Pidgin and Adium worked with 3.6.4, 3.7.0 and 3.7.1 it might be a Spark bug too.

Anyone else had this issue, or at least want to try to reproduce it for me to prove I am not losing my mind?

You are using the embedded database? There is a bug with the internal database, which was making Spark not to show rooms in the conference browser, but in the latest versions it was “fixed” to actually show the rooms, but it doesn’t show room occupants number and shows n/a instead. This is just a workaround for that database issue. I have filed this as Openfire bug OF-456. But i don’t know who and when will fix this and is it possible to fix the existing database. On my test server i started with the fresh database and it shows the rooms and the occupants numbers. Probably embedded database gets broken somewhere in the middle of upgrading from 3.6 to 3.7 format. Strange that 2.6.3 still doesn’t work for you with that workaround. Well, maybe this is completely different issue.

Nope, I’m using external Oracle database. Database was ‘created’ using 3.6.4 and upgraded to the new version (v21?) by the 3.7.1 release.

I will test with my dev environment and see if I clear out all my conf rooms and recreate one if it fixes it.

hi their you might be better doing a fresh install of openfire

I have a simuler issue with my spark install none of the tabs show up at the bottom

I can’t really do a fresh install - Conversation data has to be retained since some users are under litigation hold. I can certainly ‘fix’ pieces of the database that are not build properly, but I can’t start over from scratch.

Did some digging into this. Seems if OFMUCROOM has ‘SUBJECT’ set to null then it doesn’t appear correctly in the conference list via Spark when using Openfire 3.7.1. When I’m running 3.7.0 it works fine using an identical database.

If I either edit the room via the admin console, or update the database and cycle Openfire, the MUC room will show in Spark.

Okay, here is the real problem - Not sure if it’s an Openfire problem or Spark.

When I get a room list via Spark when a room has a null subject, Openfire sends this:



Note that the Subject field does not have a value. If I set the value of the room topic to (blank) in Openfire via admin console, it send a and the room is listed.

Other IM clients seem to handle this okay, so I’m not sure if Spark is just parsing the XML wrong, or Openfire is sending something non-standard.

I fixed this with a modification of in Openfire. Basically I set the MUC subject to ‘’ instead of null. I’m not much of a Java developer, so there is probably a neater way to do this:

final FormField fieldSubj = dataForm.addField();

String subject = room.getSubject();

subject=subject==null ? “” : subject;


fieldSubj.setLabel(LocaleUtils.getLocalizedString(“”)) ;


I think OF-440 actually ‘broke’ 3.7.1 with MUCs with null subjects when using Spark, although I realize they were fixing something else in the process. I still don’t understand why stock 3.7.1 works with Pidgin and Adium, but not with Spark.

I’m not sure is it a wrong xml sent by Openfire, but i think Spark should still show such rooms. Anyway, i have filed this as two bugs: SPARK-1462 and OF-493.

I have assigned a developer to that for a 2.7.0 fix.

I am also having the same problem in previous version of openfire had no problems, but now I can not createconference rooms, please resolve this problem quickly, the company that it needs much work!

thank you

Can you not create conference rooms, or can you just not see them? If you roll back to Openfire 3.7.0 it will resolve the ‘can’t see conference rooms in spark’ issue.

Spark 2.6.3+ has the option to hide the tabs on the lower part of the window. Some user actions were moved to the menue. This is an intentional change. If you can not see the tabs for conferences, please review your preferences.

What is the same problem? No tab for conference? It’s a check box in the appearance preference.

I reviewed this issue for Spark and it seems that its an error related to smack.

If the subject is for that room is null, there will be no value element in the muc#roominfo. in smack will only check if the subject is null, but not if the subject entry has

any values. In this specific case, this will leed to an nullpointer exception.

I created SMACK-362 and provided a patch for that issue. (501 Bytes)