Connecting To Openfire Server


I am new to setting up this sort of thing, so excuse me if im asking stupid questions. I have setup an openfire Server, and it is running an internal database with all of the default settings. I have set the server name to, and i have this subdomain pointed to my external IP address by my hosting provider. I have also forwarded port 5222 from my router to port 5222 of the internal ip address that openfire is running on. The name of the computer, the host name is “server”. The problem that i am having is that if i try to connect from another computer in my lan using i get an error and cannot connect, however if i use server as the jabber server name then i can register an account, however it still will not let me log in, i get a username/password error. Could someone please tell me whether i have this configuration correct and if there is anything else i need to do in order to get this to work both internally and externally as i would like to have clients both inside my lan and coming in from the internet. I have done my best to explain everything i have setup, Thankyou


  • OS is the openfire server
  • DNS entry did you make for the server
  • Client are you using

Ideally the openfire server should be named with the same Fully Qualified Domain Name as the server you are installing it on.

Sorry, The operating system is Windows XP home SP3, i have not made any DNS entry, i have my site and DNS controlled remotely, and i have asked the provider to add a subdomain which is pointed to my networks external ip, ie when i use nslookup and type in it responds with my external ip address. i have tried multiple clients, mostly however i am trying to use jabbim

Since you are using Windows XP have you allowed all traffic for Openfire in the windows firewall. There are a lot of ports that you should open. Without a valid DNS name you will not be able to connect to the server easily. Attached is a pic that shows an example of how the client should be configured. I would also like to suggest using Spark client. The server has many advanced features that only work with Spark.

Thanks for the reply, I have disabled the windows firewall until i get things working, just to ensure that it is not a part of the problem, when you say a valid DNS name, how does that differ from what i have described above, as i said earlier i apologise but im fairly new to this, i do not host my own DNS server, it is hosted elsewhere and i have asked them to point the subdomain at my external IP which has port 5222 opened and forwarded to my openfire server machine. I have also tried using spark, to no avail. Thanks again.

EDIT: Using spark i am able to login but for the server name i have to use the computer name which in my case is server, i cannot use the domain that i have setup, why would this be?

do you have an internal DNS server of some sort as well? That would be why it is found by an internal name.

I am not aware of any DNS server, i have 3 computers, 2 running XP home, one running vista Premium, a Digital Video Recorder and my Dlink G604T router. Thats it. I Have not consciously installed a DNS server.

Edit: I can get access to this from the outside world, i have logged in from a remote network, (my phone) but hey it still worked, that counts for something, so there is no issues there, its only the fact that on my laptop i will have to change the server name depending on whether i use my own network or an external one.

Once you have a valid DNS entry for the server from your hosting company you should not need to change a thing. Make sure your openfire server name (Server Information page) is set to the external DNS name, the xmpp.domain (Server Properties page) is the external DNS name, and the certificates match this name.


I Have played with this some more. If i use spark i can connect to my server, but only if i use the computer name, from inside my network i cannot use, which is frustrating, i also cannot use anything else but spark, i have a mac and would like to connect using ichat, but that doesnt happen either, the only way i even get a response from the server is to use jabberid@ipaddress, which is even more annoying that using the computer name, i have had an external spark client connected using, but there has to be something causing all of my problems i just dont understand what,