powered by Jive Software

Connecting to wildfire on the same machine

Hi,

I have a process which is running in the same machine where the wildfire is being installed. I have opened up the necessary port : 5222 for communication. This process will be like a client program which will connect to the wildfire. However, when I run the process, I encountered an XMPP Error 502, which either stated that cannot resolved hostname or connection timeout.

This process has been running fine when I first installed the wildfire. It only starts to fail after i shift my machine to another location. Please advise me for the possible causes as I have tried using localhost and 127.0.0.1 as the server name, which too failed.

Thanks in advance.

Regards,

Lain

Hi,

do you move Wildfire and your client to another server? “starts to fail after i shift my machine to another location” is a little bit hard to understand for me.

LG

Hmm… The wildfire and the client is still on the same server. But there is a movement of the server from one location to another. Therefore, there is a IP change.

Hi,

are you using the IP address or a server name (xmpp domain) to connect?

You may need to update the DNS record.

Or change the IP address the clients are using.

If you did specify an IP address as the server name you have a problem as it’‘s not possible to change the xmpp domain. Actually it is possible but you’'ll need to update all database entries manually which contain your current server name (roster entries, MUC logs, …).

LG