powered by Jive Software

Connection Manager bug? Cannot resolve DNS name of linux hosts

I install Openfire server in LAN and there do not have domain name. I set openfire server name to ‘‘abc’’, and let client specify the real IP( to login.

I install a CM to another linux server, set the config of server to ‘‘abc’’, and add a line “ abc” to /etc/hosts file for DNS lookup. I ping abc and the DNS name is successly resolved to But when start CM, It cannot connect ‘‘abc’’ server and show some errors:

2007.04.11 19:52:55 org.jivesoftware.multiplexer.ConnectionWorkerThread.createConnection(ConnectionW orkerThread.java:223) Error while connecting to server: abc(DNS lookup: abc:5262)

org.xmlpull.v1.XmlPullParserException: expected start tag name and not / (position: START_DOCUMENT seen (ConnectionManager.java:143)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessor Impl.java:39)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructor AccessorImpl.java:27)

at java.lang.reflect.Constructor.newInstance(Constructor.java:513)

at java.lang.Class.newInstance0(Class.java:355)

at java.lang.Class.newInstance(Class.java:308)

at org.jivesoftware.multiplexer.starter.ServerStarter.start(ServerStarter.java:95)

at org.jivesoftware.multiplexer.starter.ServerStarter.main(ServerStarter.java:49)

Any ideas?

Openfire 3.3.0 released, the CM does not fix this bug?

Hey adun,

The stack trace that you posted is showing that the CM is able to open a socket connection to the server. However, the connection is getting closed for some other reason. Have you configured a password/shared secret in the server for connection managers? Enabling the debug log on the server will help you figure out the reason for the disconnection.


– Gato

I have configured a password in openfire server. Now I will have more test.

How to enable debug log? on openfire server or CM?

But I view from error.log of CM, It seems CM cannot resolve ‘‘abc’’ to real IP address.

Now I move CM to Windows system with the same configure, It’'s work fine.

It seems Openfire and CM does not support linux very well. I occur many problem under linux, but move openfire and CM to Windows, It’'s all fix.

Maybe you should post your configuration (remove the passwords). This looks like a syntax error.

I just open configure file and add domain ‘‘abc’’ and password ‘‘abc123’’.