powered by Jive Software

Connection Manager Exception

I just installed the connected manager on my Linux machine. Tried running connection manager by typing

sh cmanager.sh

I get an exception as follows

Exception in thread “main” java.lang.UnsupportedClassVersionError: org/jivesoftware/multiplexer/starter/ServerStarter (Unsupported major.minor version 49.0)

at java.lang.ClassLoader.defineClass0(Native Method)

at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)

at java.net.URLClassLoader.access$100(URLClassLoader.java:55)

at java.net.URLClassLoader$1.run(URLClassLoader.java:194)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:187)

at java.lang.ClassLoader.loadClass(ClassLoader.java:289)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)

at java.lang.ClassLoader.loadClass(ClassLoader.java:235)

at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

How can I resolve this ?

Hi SNatarajan,

Check your java version and try to update to the latest one.

I installed the latest JDK and JRE and still having the same problem. The “java -version” prints

java version “1.6.0_01”

Java™ SE Runtime Environment (build 1.6.0_01-b06)

Java HotSpot™ Client VM (build 1.6.0_01-b06, mixed mode, sharing)

Am I missing something ?

It worked. I had to change the JAVA_HOME to point to the newly installed jdk location