Connection Manager - not working


I am using connection manager the only the latest release official 3.0, I am using the default port in the server and on the connection manager port 5262 with a simple password. Is there any way to troubleshoot connection manager, which is running on W2K3?


Welcome to Jive community

A good way to start troubleshooting is to look at the log files. These files are located in logs directory where you install the connection manager (CM). Likewise, the log files for Wildfire is located in logs directory where you install Wildfire. Because CM connects to Wildfire, you might want to look at both places.


The log in the connection manager is empty and any ideas which log on the wildfire server I should review as I have 3 logs all over 1MB.



are you sure that the clients connect to the CM?

Are you also sure that the CM connects to Wildfire?

In the CM you must configure as xmpp.domain a DNS name or IP address which connects to Wildfire. If you use there your xmpp.domain name (e.g. which you also use in Wildfire (e.g. it will not work.



The log in the connection manager is empty

That could possibly means that users have not connected to the CM yet. CM will not connect to Wildfire immediately when it starts. The CM->Wildfire connection will be established in “on-demand” basis, i.e. when a user connects to the CM.

Hi Thanks for the responses.

The clients are pointed to the connection manager’‘s ip address and each client is reporting the following "can’'t not connect to server: name invalid oe server unreachable".

The manager.xml file has the IP address of the wildfire server, the port 5262 and the password identical to that of the wildfire server.

I can telnet from the connect manager system to the wildfire server via 5262 and connect successfully.

How can I verify the connection manager is running?


How did you run your connection manager?

In my case, I run it under FC5 and here’'s what I do to run it:

JAVA_HOME=/usr/java/jdk1.5.0_08 sh &

To verify that it’'s running, I simply run:

ps auxw | grep cmanager

and it gives me something like the following:

jive 2777 13.0 1.8 256540 18720 pts/7 Sl+ 00:08 0:00 /usr/java/jdk1.5.0_08/bin/java -server -DmanagerHome=/opt/connection_manager -Dcmanager.lib.dir=/opt/connection_manager/lib -classpath /opt/connection_manager/lib/startup.jar -jar /opt/connection_manager/lib/startup.jar


My wildfire is running on FC5 and the connection manager is on W2K3, I have executed the batch file, resulting in a quick pop up screen and then nothing. It is not listed as an application running in task manager. I have the latest java installed 1.5 and the JAVA_HOME environment was set.


Can you try opening up a Command Prompt window, navigate to the CM directory and run cmanager.bat there?

That producted the same result

That’‘s wierd. When I run CM on my XP, the command prompt with “Connection Manager” opens and stay there. And I always got something in my logs/info.log. If there’‘s error, there’'ll be something in logs/error.log too. BTW, what do you get when you do “echo %JAVA_HOME%” in the command prompt window?

The echo results “C:\Program Files\Java\jre1.5.0_06”

Can you edit manager.xml and modify the botom lines as follows and rerun the CM:


See what you get on the screen as well as in connection_manager\logs\debug.log

Sorry, I can’'t help you much.

Message was edited by: aznidin


as it is started with a “start …” command you’'ll see nothing if you run the script. But you should see “java.exe” processes in the task manager if it runs. So if you want to stop them you may either logout as this should kill the processes or kill them directly.

Try to start it manually in a cmd with

cd C:…\connectionmanager\bin

%JAVA_HOME%\bin\java" -server %JVM_SETTINGS% -jar …\lib\startup.jar


Hi thanks for the advice.

Using the command line without “start”, I was able to determine the error was that the connect manager was looking for a “jvm.dll” file in the %JAVA_HOME%\bin\server directory, but the server directory does not exist and only the client directory has that file. I created the folder “server” in the bin directory and basically a copy of the client folder. The connection manager is now working, I think!! The black screen remain with Connection Manager 3.xx etc, but the spark client is reporting invalid username/password when I am trying to sign in and the connection manager system is set as the server for the client.

The wildfire error log shows the following:-

2006.10.06 17:00:00 04) Connection closed before session established


Please note direct loggins to the server with the same user name is working ok.

Any ideas where to start?

That line in Wildfire error log doesn’'t explain much. It only says that a connection has been established but somehow a disconnection occurs. In fact, it is more like an information than an error.

If there’‘s really anything about error it should show in CM’‘s error log. But first thing first. It seems to me you’'re having a broken JRE. You should not be seeing a totally blank screen and empty connection_manager\logs\ directory. Perhaps new installation of JRE or even better JDK would fix that.

This problem has been resolved with the upgrade to wildfire 3.1.0