Connection manager

Is there any way to connect a remote server running connection manager with a home server running wildfire? I have an office cross country from me and would like to hook them up


the connection managers do currently not support s-2-s connections. “For now the main focus is c2s connections since that is the main bottleneck for achieving great scalability.” (src: ) So you need to establish a direct s-2-s connection.



What LG mentioned was correct if it is s2s because that’‘s logically the case if server entities are located in a distant. So, you’'ll have one of them having a domain name, and the other having another domain name.

However, if you really mean to connect a CM with Wildfire under one domain name, then technically, the answer is yes although your mileage may vary depending on how you want the entire system to work. There are a number of issues that you need to resolve; for example, whether to load balance, whether you need an SSL cert, how to make addresses resolveable, etc.

The purpose of the CM is scalability. With such purpose, a normal aproach would be to have the CM and Wildfire located in a way that network latency is minimized, typically within the same LAN. But that doesn’'t stop you from breaking the rules

So I am assuming i could not establish a c2s connection if they are not on the same LAN?


do you want to use a CM at office A to connect to a Wildfire server a office B? This should possible, no matter where the CM is located. Anyhow all clients will try to connect to the CM as your xmpp.domain must resolve to a server name. Or you need to setup a DNS entry for every office.

The further CM configuration is as far as I can tell tricky as one must specify the xmpp.domain in the manager.xml file as the server you want to connect to. So I did add an entry in /etc/hosts to make sure that the CM resolves xmpp.domain as the Wildfire server and not its own IP address.


ok, cool… I’'ll try to get something working!

Ok, I’'ve been trying to set up a connection between a remote connection manager and our server, and I am obviously not doing it right. The CM is off of our network running on a server across the country. I opened firewall ports 5262, 5222, and 5223 on the domain hosting wildfire. My manager.xml file is below… can anyone see what i am doing wrong?


you did post the solution here:

a complete other name or IP address which does not matches the xmpp.domain of your Wildfire server.

thanks it, but im a little confused about what you put here:

+PS: The connection manager does not need to specify the xmpp.domain according to Gato, so you can specify here:

a complete other name or IP address which does not matches the xmpp.domain of your Wildfire server.+


let me try it with an example: is your Connection Manager, it has the internal name is your Wildfire server, it has the internal name is your xmpp.domain

So you set up a DNS record for =

If you use “” as the xmpp.domain in manager.xml the CM can never connect to Wildfire.

But you can use “” or “” as the xmpp.domain in manager.xml without problems. The CM itself does not need to know for which xmpp.domain it is used and calling this property xmpp.domain in manager.xml is really confusing.



What LG meant is that, if:

ftp is the same as ftp

telnet is the same as telnet

ssh is the same as ssh

blahblah is the same as blahblah

then, you can put either or in property of your CM’'s manager.xml. Eg: is the same as

I hope that’'s clear.

Now lets look at what xmpp.domain means.

Say that you want to host Wildfire and you want users to connect to CM as That means your xmpp.domain is and here’'s what you need to do:

  1. Your clients must be able to resolve to CM’'s IP address either through DNS or a simple entry in /etc/hosts file.

  2. Login to Wildfire Admin Console at

  3. Under Server ->Server Settings, edit Server Name to contain

Hope that helps.