Contact roster still not updating- Possible explanation?

I’'ve recently upgrade my Wildfire server to version 3.0.1 and my clients still do not see their contact roster update dynamically. They have to sign off & sign back on in order to get an updated list.

What I’'m wondering is, could it be due to system resources? I currently have ~150 users on the server, and the server is running all required applications: Wildfire & MySql 5.0x. The hardware is:

-Pentium 3 1GHz

-512MB RAM

-2-4GB swap on its on hard drive

-Windows2000 Professional SP4

I’‘ve currently for my VM options set to give Wildfire ~200MB (wthat thats doing to the rest of the system I don’‘t know). I’'ve thought about migrating my database & software to Ubuntu Linux on comparable hardware.

Would I get a boost in performance? And could this correct my “presence” problem? I can also request a faster PC with lost more RAM.

Hey Pc_Pixel,

We would need to get from you a step by step list to know how to reproduce your case. Other option would be to get a vmware image that reproduces the problem.


– Gato

I have this similar problem.

My data:

Server: Wildfire 3.0.1 (installed from the package with java included, internal database)

1.5.0_07 Sun Microsystems Inc. – Java HotSpot™ Server VM


Windows XP / x86

cs_CZ / Central European Time (1 GMT)

Java is using max 30% of its memory.


Psi 0.10, Windows XP

When one client changes its presence, status is not propagated to others.

I don’‘t know if it is the problem of the Psi clients or not. I didn’'t have time to try another clients.

No routers, only small LAN and about 25 clients.

Thank you for your answers.

Ok, well let’‘s see what I can do. Here’'s my set up:

-Pentium 3 1GHz (Intel 815EEA mobo), 512MB RAM, 40GB Hard drive & 6GB hard drive (40GB holds OS & Database, 6GB is dedicated swap), Windows 2000 Professional SP4, Java Run Time 1.5.0_07, Wildfire 3.0.1 and MySQL 5.x. 80% of my clients are using Spark 1.1.4. I have a handful that use Psi or eXodus.

I tried a basic test when nobody was connected to the server. I connected two users and checked presense. It worked. However, as more and more users connect to the server it looks like the updates do not occur. People have to sign off & sign back in to get the updated contact list.

My original VM memory options were set to 175MB and Wildfire seemed to stay at ~80-95% memory usage & then all of a sudden clean itself up but would get back up there. I currently have it set to ~300MB. At the time of this posting, I have 43 users connected and memory usage for Wildfire is reported to be 136MB. The server has been online for ~13 days.

I don’‘t have a copy of VMWare to make a virtual machine. If you needed an image/machine, I could try to make one using something else. I don’‘t think the problem is client specific but I’‘m not quite sure what’'s happening.

In my case, the users added their contacts manualy.

I have created groups and set them to show in rosters.

Now the presence is working fine.

I have the same problem. Running Redhat Enterprise 4 under VMWare authenticating against AD2003. Roster is populated upon login, but not updated after that. Server has one processor and 1GB of RAM assigned to it, but we are only testing with like 8 users.

It’'s definitely my groupSearchFilter. I removed it and everything started working.

Here is what I have. I am trying to find out what I’'m doing wrong in it though.

Anybody? I’'ve tried a couple different rearrangements to no avail. This really makes the group publishing a hassle because all my groups from AD are listed in the Admin Console.

Well I can safely say it isn’'t resource related.

I just migrated my IM server from: Pentium 3 1GHz, 512MB RAM, Win2K Pro SP4, Java 1.5.0b8, MySQL 5.0, JVM set to 300MB

to: Pentium 4 2.4GHz, 2GB RAM, WinXP SP2, Java 1.5.0b8, MySQL 5.0, JVM set to 512MB

The contact roster worked ONCE. I was able to see one person sign on. Then it stopped updating. I have to quit the client compeltely & sign back on in order for it to update.

Any progress on this one? Possibly fixed in 3.1?

Mine work just fine on LinuxPostgresLDAP, I upgraded to 3.1b2 (I wanted to play with the gateway plugin) and I am using the same config file from 3.0.1. The gateway plugin doesn’'t seem to play nice with LDAP, the developer is investigating, but that is not an issue… the thing is that now I started to get the same behaviour reported on the thread, so I will rollback to 3.0.1 tonight.

I just upgraded my server from 3.0.1 to 3.1.0. The upgrade went flawlessly, but the roster problem ha snot gone away.

I’‘m at the point right now where I’‘m going to blow away my common shared group & tell users they’'ll need to build their own lists to see if that fixes the problem.

Why is this still happening?

I also have this problem as I mentioned on another thread. I don’‘t want to have users build their own roster groups because it’'s painful to do so.

See my most recent post on “i think i know why!”. It has something to do with the way groups are shared.