powered by Jive Software

Contacts are not showing up for Yahoo

I’'m trying to setup Yahoo up and I can see the Yahoo Transport! which is Green (online). However, I cannot see any contacts from my Yahoo account. Here is my environment:

Wildfire 3.2.0 - Windows 2003

Spark 2.4.1 and Spark 2.0.8 (Both respond the same way)

IM Gatway 1.0 - latest

I have cleared cache, restarted the service, logged out and then back in about 50 times and not sure what is happening. Also, here is the log that it generates. Thank you.

2007.03.29 11:05:03 [org.jivesoftware.wildfire.gateway.protocols.yahoo.YahooSessionListener.inputEx ceptionThrown(YahooSessionListener.java:191)

] Input error from yahoo: Source: InputThread

java.net.SocketException: Connection reset

at java.net.SocketInputStream.read(Unknown Source)

at java.io.BufferedInputStream.fill(Unknown Source)

at java.io.BufferedInputStream.read1(Unknown Source)

at java.io.BufferedInputStream.read(Unknown Source)

at ymsg.network.YMSG9InputStream.readBuffer(Unknown Source)

at ymsg.network.YMSG9InputStream.readPacket(Unknown Source)

at ymsg.network.DirectConnectionHandler.receivePacket(Unknown Source)

at ymsg.network.Session$InputThread.run(Unknown Source)

Known bug =) GATE-104

I haven’‘t the slightest idea what’‘s causing it. Lots of people have tried to help me track it down and I’‘ve yet to determine what’‘s going on. That said, the ymsg library doesn’‘t have an active developer at this time. However, one of the regulars on these boards is actually working on a branch of ymsg that is aiming to fix the bugs I’'ve been running into. =) Stay tuned!

Is there anything I have to do in the External Component Settings?

Nope! (because they are internal components)

Alright. I finally figured out my problem and got Yahoo IM working. I thought if the client machines had WEBSENSE rights (not being blocked) from the IM protocols, I was good to go. Well, it turned out that the server didn’'t have rights to those protocols and once I gave those rights, IT WORKED.

Awesome! Glad to hear it!

I had suspected that this was caused by a firewall issue as well but ive not been successful in finding out what the exact problem is. I just do not see anything in our sonicwall logs that show traffic from the WF server being blocked. At least you have given me hope that the problem can be solved.