powered by Jive Software

Could not bind to One IP

Hi,

I have installed wildfire 2.4.0 in one of our Linux servers where apache too is in use, we have two nic cards and hence I want Wildfire also to run on port 80(already apache is listening on port 80). But I could start the wildfire server only when the apache service is stopped. I could also connect from exodus using my both ip’'s which means wildfire binds itself to all the interfaces available. I could start apache only when wildfire server is stopped. But I am sure that apache have bind to only one interface, which I have specified in httpd.conf file. I tried editing the xmpp.socket.plain.port and xmpp.domain but all in vein.

Can anyone help me to make it listen to a single interface ?

Thanks

Hi,

to bind the web admin console (port 9090/9091) to an interface you need to modify conf/wildfire.xml and add the line “”, it will look like this:

/code

To bind all XMPP sockets to one interface there are four System Properties you want to set to an IP address like 192.168.1.1 (not eth0) using the admin console:

xmpp.server.socket.interface

xmpp.component.socket.interface

xmpp.socket.plain.interface

xmpp.socket.ssl.interface

Using low ports is something only root users can do, running Wildfire as root is maybe not a good idea.

LG

Thanks bro…Now it works, by adding all the properties you have metioned…

Thanks …

Where we can read more about these system properties ??