powered by Jive Software

Could not find UserManager

I just installed wildfire 2_5_0 on mandriva 2006 with the RPM, created database ‘‘wildfire’’ and user ‘‘wildfire’’ in MySQL, commented out the ‘‘skip networking’’ in the mysqld config file, assigned all the correct priveledges in MySQL, ran the SQL script to create the table, and verified all was correct. I then loaded the config page in my browser and entered the information for mysql and the username and password. All went well until I had to change the password for admin. I got the error:

There was an unexpected error encountered when setting the new admin information. Please check your error logs and try to remedy the problem.

The stderror.log says:

Could not find UserManager

Any suggestions? I have searched this forum and found nothing relevant.

Hey jfriedeck,

Could you check the error.log and paste the complete error?

Thanks,

– Gato

The error.log in /opt/wildfire/logs is an empty file.

I’'m also getting a strange indication when I try to start the service from service manager. It says:

Usage /etc/init.d/wildfired {start|stop}

The wildfired script is very much like other scripts. It stops fine but gives me this message when I try to start it. Very strange.

When I restarted the machine the wildfire service started but it still does not go beyond the password change screen.

Hi,

what is the “service manager”? Maybe it does execute a “/etc/init.d/wildfired status” to verify whether Wifi is running, this would explain the message.

LG

The service manager is a tool in Mandriva that starts and stops services (daemons) and manages their boot-time operation. The response from the wildfired script was unexpected. According to the script, the response indicated that the ‘‘start’’ was not recieved by the script and I could not see how that was possible. This, overall, is not the problem. The fact that the error log indicates ‘‘Could not find UserManager’’ and I cannot configure the admin user is the real problem.

There was another entry in this forum that was solved by removing trailing information in the Java database specification text box on the admin password screen (the last thing you set up during install). My installation did not present that trailing information so I did not see how it affected my problem. I can’‘t find information in my allotted time that would indicate how to fix this. Everything up to this point works great but I need to assign a password to the admin user and I can’'t.

Any ideas would be greatly appreciated. Thanks.

And yes, that would explain the message. I hadn’'t thought of that!

Thanks!

i’'m having the same problem with mandriva 2006.

i skiped the password set on instalation and change config xml to use ldap accounts.

i think the problem is related to database, i created a group (the group is configured to use mysql, just the users are in ldap) and the only information on jiveGroup is a ‘’?’’ char on description field.

Try to put this string on db url ?useServerPrepStmts=false

I will try that tomorrow when I get back in town. Thanks!

works for me

All better!

Thanks for the help. That fixed it.

Thanks a lot!