Couple of questions about Red5 with Spark 2.5.8

Hi,

Despite reading a lot of threads in this forum I still can’t get Red5 running on Openfire / Spark without errors.

What I have done so far:

  • Installed the latest version of the Red5 plugin for Openfire (version 0.20) that I could find.

  • Copied the latest red5-plugin.jar file (version 0.0.6?) to the spark plugin folder (Windows XP, used %APPDATA%\Spark\Plugin).

  • Enabled the http_bind in Openfire to 7070 (and changed it to 8080 later).

There are some things I don’t fully understand. I’d appreciate it if someone can help me out.

  • In another thread Dele writes: " Enable http-bind in
    Openfire to either port 8080 or 7070. Red5 plugin will check property
    "httpbind.port.plain" and use whatever value is set
    ". But for some reason the Red5 plugin in Spark tried to connect at port 8080 instead of 7070 which was binded at that time? Does this mean the plugin doesn’t correctly read the property “httpbind.port.plain” or could it be something else?

  • What is the Red5.properties file being used for? I edited the file with the hope that I could force the plugin to use port 7070, but nothing happened. Then I read in this topic (http://www.igniterealtime.org/community/docs/DOC-1480) that Amarx customized the plugin to use the red5.properties file in the Spark folder. I tried to get the plugin to work at port 7070 by placing the file in the Spark folder but didn’t see any effect. I’m not sure if the plugin uses the red5.properties file at all?

  • Is the latest version number of the Red5 plugin for Spark 0.0.6 or
    is there a newer version? If so, where can I find it? I could only find
    information about the Red5 plugin for Openfire. Possibly the newest
    Openfire plugin also has the latest plugin for Spark, but can someone
    confirm this?

  • When I used the plugin in Spark, I noticed that it was still trying to
    connect at port 8080, despite of the port 7070 that I bound in Openfire.
    At the end I got Red5 working after changing the http_bind in Openfire
    to 8080. But this seemed to give me unwanted side effects, like not
    being able to use the contact search (i got a message the service was
    not available) and users where shown as offline instead of online (which they were). Is there anyone else who experienced this?

I hope someone is willing to answer these questions.

Thanks in advance!

-Patrick

Does this mean the plugin doesn’t correctly read the property “httpbind.port.plain” or could it be something else?

If jve global property “httpbind.port.plain” is not created, Red5 plugin assumes 8080. I will change this to “7070” in next version

I tried to get the plugin to work at port 7070 by placing the file in the Spark folder

I suspect that should be the Spark folder in “documents and settings”, and not the one in “program files”

Is the latest version number of the Red5 plugin for Spark 0.0.6 or is there a newer version?

0.0.6 is the latest

When I used the plugin in Spark, I noticed that it was still trying to connect at port 8080,

As far as I can see in the code (spark folder), the only way this can happen is that is that there is no jive “httpbind.port.plain” property on the server or there is a file called red5.properties in X:\Documents and Settings\YYYYYY\Spark with port=8080.

Have a look at the Spark log file. It will tell you where the port value was taken from.