powered by Jive Software

Custom database integration with MySQL, cant get it to work

Hi,

Yes i have read

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/db-integ ration-guide.html

I have tried over and over and i cant work out why my external DB integration isnt working:

There are no errors thrown in the logs, there doesnt seem anyway to troubleshoot this. I have looked through the forums, and i still cant work out why this is going wrong. It doesnt seem to make sense.

I have attached my config file, tested all of the sqls and theres no problem with them, the connection details are all correct.

I tried it without the concat for the names and it doesnt seem to be the problem either…

Can anyone assist?

openfire.xml (2972 Bytes)

Anyone?

I know this seems to be a common problem, but i cant seem to find a solution.

I read this, but i couldnt see any difference between my config file and the suggested on that LG posted… Im a bit at a loss.

Hi Richard,

do you see exceptions in the error log file?

LG

The only thing im getting in the error log file is:

2010.08.16 21:26:03 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:88)
] Line=19 The content of element type “dwr” must match “(init?,allow?,signatures?)”.

but as you can see from the timestamp, it hasnt occured for a few days, and doesnt happen every time i start up the server

Warning file:

2010.08.19 17:38:56 Property ‘provider.user.className’ as specified in openfire.xml differs from what is stored in the database. Please make property changes in the database instead of openfire.xml.

I think this warning could be pointing to the issue. I assume that this is asking me to change:

ofproperty.propValue where name = ‘provider.user.className’

org.jivesoftware.openfire.user.DefaultUserProvider

to:

org.jivesoftware.openfire.user.JDBCUserProvider

???

It seems odd that it would ask me to alter this tho…

Thanks LG

After pursuing this i found that i need to add:

org.jivesoftware.openfire.user.JDBCUserProvider

on

ofproperty.propValue

where name = ‘provider.user.className’

and

org.jivesoftware.openfire.auth.JDBCAuthProvider

directly in the database. Only then would it accept my external users. Weird, but one to watch out for