powered by Jive Software

Debug.log is empty, what's wrong?

Openfire 3.7.0 @ Ubuntu Server 10, debug.log is empty

Tried this:

  • Enabled logging in the admin console, see 1st attach;

  • Set log.debug.enabled in the system properties, see 2nd attach;

  • Inserted these lines

<log>

<debug>

<enabled>true</enabled>

</debug>

</log>

in the /opt/openfire/conf/openfire.xml

Nothing helps, debug.log still has 0 bytes. Help, please.

I’ve having the same problem. Tried the same three things to no avail.

Same problem with me… looks like nobody around here…

I’d recommend upgrading to the latest Openfire release. As of now, it’s 3.8.2. I haven’t experienced this problem before myself, but you shouldn’t need to be manually editing config files or forcing system properties override via the Systems Properties box… the radial button in Log Viewer should do the trick just fine (granted everything is working well).

Just reaching… but I would think the problem isn’t the setting of the property value, since that’s trivial and done in java memory (read in from the text config file and manipulated by the Log Viweer’s radial buttons), but rather the problem is someplace else on your system. Are you getting warnings or error logs or have those stopped too? Do they show any indication of what may be going on with your Debug log? Try clearing the Error and Warnings logs and then go set the Debug option to on and check to see if anything populates the errors, etc.