powered by Jive Software

Deploying spark with PDQ deploy


#1

I am having trouble pushing the Spark client out to my users. I have followed the steps mentioned here https://community.spiceworks.com/how_to/113818-how-to-deploy-spark-instant-messenger . The program itself seems to be getting pushed out to the end user. My problem is I cannot get the configuration such as domain name to show up. Most of the machines on our network are either windows 7 or 10 if that helps. Thanks


#2

Check if spark config files are actually copies with your script. Maybe you need to create Spark folder first.


#3

Guess I am not following, what do you mean are actually copies with my script. I configured Spark the way I wanted it to be pushed out, copied the config file into a shared network folder and then ran the script that they provided if that’s what you are asking.


#4

*Copied

Check if your preconfigured spark settings files are actually copied into needed folder on target machines. These files should go to c/users/user/appdata/roaming/spark. You may also need to first create spark folder in the same script. Not sure if copy command will automatically create one, if there is none.

You can check copied files by opening spark.properties file and checking if server field has any value.


#5

Checked the target machine and the files did not get copied into the app data folder


#6

You should investigate why it didn’t work then. Maybe its an issue with the share (can target machine access it?), maybe you need to create Spark folder first.


#7

I am guessing that you are running the script as some domain admin user. From what I found when putting in the app data folder, you have to parse through all the app data folders on the target pc, and make sure it puts the files in all of them, since the script doesn’t know which folder, is the actual user. By default I believe it just copies the files into the appdata folder of the domain admin user the script is running under, if it exists on the target pc. I believe I found some scripts that can help with getting these files moved to proper location.


#8

Well, in my case i was doing it via GPO applied to User configuration and in that case it was running with user’s, who is logging in, rights, so it was properly working with %AppData% value. Unattended Spark installation (via shutdown script GPO)