powered by Jive Software

Dial support, FQDN - Wildfire, Asterisk-IM, & Spark - where is the problem?

Hi Gurus and Newbies, hope you can help me on figuring out my setup problem.

I’'ve read a couple of postings related to the above subject, depending on the situation, my Spark connection works perfectly supporting the Dialling function.

This is a bit long… so please bear with me.

My Server setup:[/b]

CentOS Linux 4.3

Co-located Asterisk@Home 2.7 and Wildfire 2.6.2

Asterisk IM Plug-in ver 1.1

Hostname : asterisk1

Host IP: 10.0.0.8

Subnet: 10.x.x.x

Domain: headoffice

My Laptop Setup

/bWINDOW$ 2K

Spark 1.1.4

My Switch/AADSL modem:[/b]

Local DNS Domain Name: headoffice

Local DNS table list: asterisk1 - 10.0.0.8

NAT: 0.0.0.0 <–> 10.0.0.8 (making my test setup visible from the web when testing with friends via my public IP)

  • the Asterisk-IM plugin has been configured properly, communicating with the Asterisk Manager

  • In the Asterisk IM /General settings, I had the Server box filled with “10.0.0.8” (also tried it with “asterisk1.headoffice”, with the same result noted below)

  • All Phone Mappings are working OK (I think)

  • Wildfire defines Domain/Server name as “asterisk1.headoffice”

Situation:[/b]

(ON-NET)

  1. using Spark and 10.0.0.8 on the Server Address: the “Phone Dial” icon/option is MISSING

  2. using “asterisk1.headoffice” on the "Server Address, the “Phone Dial” icon SHOWS UP

(OFF-NET)

  1. As I have no registered Domain name to date, my only option connecting to the system is via my public IP address.

  2. Doing so, the Phone Dial icon is always missing

On the positive side:[/b]

when on calls (using VOIP client to dial/receive calls), the user status changes to “ON-Phone” for both IAX2 and SIP extension (and back to stand-by mode when call is released)

Checking the Server Log when I do not see the Phone Icon,

  1. it always refer to “Host Name resolution” problem on “warn tab”

  2. on trace log, Asterisk IM sends the querry to “asterisk1.headoffice”, Asterisk responds to “asterisk1”… then the Host Name resolution error…

  3. yet, whenever I ping either “asterisk1” or “asterisk1.headoffice”, it always get resolved to “10.0.0.8” (using any other PC sitting on the same subnet)

Thus, back to my original question…[/b]

Where is the bug?

  • Is it in the Asterisk IM plug-in? Or Wildfire? or Spark? or Asterisk Manager maybe?

Oppsss… not really asking where is the bug… but more on Please help… i want the “Phone icon” to appear on either scenario…

again, apology for the litany

Cheers

erick

Hi All,

I’'m not an expert on this so please correct me on interpretting the Wildfire “warn.log”

As follows:

==============================================

006.04.28 21:54:49 Closing session due to incorrect hostname in stream header. Host: 10.0.0.117. /bConnection: org.jivesoftware.wildfire.net.SocketConnection@12e43f1 socket: Socket[addr=/10.0.0.117,port=32818,localport=5269] session: null

==============================================

The above message appeared when logging-in (with Spark) using the IP server address rather than the FQDN.

Note how the message was relayed: Host: 10.0.0.117 /i(should that be Host: asterisk1?)

  • asterisk1 is my server’'s host name.

Also, I did an ethereal trace and got a similar result.

the wildfire (or asterisk IM) application appears to be doing a DNS lookup for “10.0.0.117”, the DNS server responding with “not Found”

  • maybe that’'s why it works when I use the FQDN on the Spark server field.

with the FQDN, I can see on the trace that the DNS lookup message is asking for “asterisk1.headoffice”, and the DNS server returning the IP address of “10.0.0.117”

Any takers?

Cheers

Erick

just a correction…[/b]

I did some dissecting of the DNS packets captured by ethereal.

using either the IP address or the FQDN on the Spark Server field results CORRECTLY to the correct wildfire server address. (if FQDN is used initially- the DNS server replies with the correct IP address, if the IP address is used, a reverse lookup occurs and the DNS returns the FQDN value)

  • however, this is happening at a packet level monitoring the communication between SPARK and the DNS server during logon.

  • at the application level, the Spark/Asterisk-IM/Jivewire application (no idea which one is causing the problem)… provides a different result. ie. problem noted above.

Cheers

Erick

ITS ACTUALLY A DESIGN PROBLEM

if the jivewire server name settings/properties is filled using the server IP address,

AND in Spark, the same IP address is used for the Server field

YOU will see the Dial Icon

if the jivewire server name settings/properties is filled/defined using the FQDN

AND in Spark, the same FQDN is used for the Server field

YOU will see the Dial Icon

If cross paired: NO DIAL ICON

Anyone, please advise what’'s the solution to make the cross paired combination work

cheers

erick

Sorry, might not help, but perhaps to get around the issue you could just create an entry in your hosts file with your public IP and the fqdn, which will allow you to enter the fqdn in Spark?

Ben