Disable broadcasting for certain users?

i’'m new to wildfire/spark, so bear with me. ive downloaded the broadcast plugin and i can use it and it works…but so can everyone else. is it possible to take away the ability to broadcast messages from all users except for admins or something?

update: im looking in the server manager properties and looking where the plugin.broadcast.serviceName should be so i can edit it, but its no where to be found. do i have to create the property myself?

Hey Hulkster,

Check out the read me file of the plugin. As you can see you can use the plugin.broadcast.allowedUsers system property to define which users are allowed to broadcast messages to all users. System properties are managed in the System Properties menu item located in the main page of the admin console. You should add these new properties to the list.


– Gato

thanks for the reply. so what ive done is to add the property: “plugin.broadcast.allowedUsers” and then of course the read me says to make it a comma delimmited value…so i put in 3 users that i want to have access to broadcast messages. this is what i have as the value: “jsmith, tjones, bwillis” as it corresponds to their user name. is this correct?

Hey Hulkster,

I guess that we need to improve the readme file to make it explicit that

you need to specify a complete JID not just a username. So in your case

you need to have something like:

"jsmith@myserver.com,tjones@myserver.com,bwillis@myserver.com" where

myserver.com should be replaced with your actual value. BTW, you will

need to restart the plugin so that these changes could take effect.


– Gato

cool! thanks. yeah you need re-word your readme with the @server.com on there for morons like me who dont know any better just a suggestion.

k, its still not working. for the property value, i typed in "tsmith@myserver.com, tjones@myserver.com" (yes i replaced myserver with the right one), and then restarted the plugin. i exited out of spark and came back in, but i still have the ability to broadcast, when i shouldnt. i’'m trying to test it on myself by the way. is it case sensitive as far as the commas and stuff goes? like… “name, name” with a space after the comma, instead of “name,name” without the space…does that matter?

thought it was correct…but it’'s not fixed yet


I have the same problem. let me know if you fix it I’'ll do the same!



aw man, i got all excited when i saw a reply but alas, no answer.

Hey guys,

I just tried it here and it is working fine for me. How are you sending

the broadcast message? Are you sending a message to

all@broadcast.myserver.com (where myserver.com should be replaced by

your real server name)?

One other test you can try is to add all@broadcast.myserver.com to your

contact list. Only people allowed to broadcast messages to all users

will be allowed to add the all group. BTW, if you are using Spark and

using the broadcast feature then I’‘m afraid that it won’'t work. Spark is

not using the all@broadcast service and instead it is sending a message

to each user in the roster.

Let me know how it goes.


– Gato

Yep, that my problem! is there a way disable throught config file or a plugin? I seen talk about a plugin but no link.

a plug would be great then i can deploy it this the install.


Message was edited by: darkjedi

Hey Jeff,

Advanced controlling of client and server features is offered in

Wildfire Enterprise. For instance, Wildfire Enterprise will also let you

to disable/enable file transfer, group chat (i.e. MUC) or vcard/avatar



– Gato

Hi Jeff,

this seems to be the third post about Spark broadcast … and it should be once again be fixed within Spark 2.0


I also want to restrict broadcasting to a small number of users. I’'ve tried every thing I can think of but now I just want to disable broadcasting all together. Is that not possible with Wildfire 3.10 (open source) and Spark 2.0.4? Removing the plugin from Wildfire does nothing. Thanks for any suggestions.