Disable conference room (muc) history

First post here and I have to start with this… Openfire and Spark are great products! We’ve installed these for internal service only as we are spread out over several Northeastern states and Canada. Thanks for creating a valuable tool for business!

One item my boss has asked me to work on is the conference room history. He would like to open a conference room and not see any prior conversation each and every time that room is opened. I’ve read through the threads searching by the XML fields listed below and changed the following, restarting the Openfire server each time. While the settings seem to clear the history prior to a restart of the service, conference rooms will still show prior conversations from that restart forward.

**xmpp.muc.history.maxNumber = 0 **does not appear to work for us.

**xmpp.muc.history.type **and tried “none” and “0” but the conference rooms still show previous conversations.

I’m unsure if these have a timeout value (just started working on this this AM) and will clear when the conference room is opened later? Everything else works GREAT so far. LDAP is a significant advantage.

Running on a Windows 2003 server with SP2 (vSphere Guest OS) and Microsoft SQL 2000 with SP4. Openfire 3.6.4 and Spark client 2.5.8

Thanks for your assistance in advance!

-Eric @ Sprague Energy

Evidently, the settings listed above (none and 0) work if you restart the service. I am still unaware of any timeout value that can be set for the already-entered text in the conference room and can this value be edited by the Admin?



What about setting history to “Don’t Show History” via gui at Group Chat > Group Chat Settings > you conference service > History Settings ?

if I put Don’t Show History, I never receive message offline. =/